summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 10:47:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-30 09:34:51 +0200
commit22556541f91333560578ac7523f89c7fdd85ee8f (patch)
tree65c801c5e91c9213d864922562d121bdfe6d6921 /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 14.0.3 (diff)
downloadgentoo-22556541f91333560578ac7523f89c7fdd85ee8f.tar.gz
gentoo-22556541f91333560578ac7523f89c7fdd85ee8f.tar.bz2
gentoo-22556541f91333560578ac7523f89c7fdd85ee8f.zip
sys-devel/clang-runtime: Bump to 14.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.3.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.3.ebuild
new file mode 100644
index 000000000000..f0ec98510540
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"