summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-03 12:58:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-03 13:12:57 +0200
commit8d7555ef4aac5d902e38a3d63ea051284e36cf59 (patch)
tree5a82cdbd6fffd67a7876a9c1d3565c7a47b20cd2 /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 13.0.0rc1 (diff)
downloadgentoo-8d7555ef4aac5d902e38a3d63ea051284e36cf59.tar.gz
gentoo-8d7555ef4aac5d902e38a3d63ea051284e36cf59.tar.bz2
gentoo-8d7555ef4aac5d902e38a3d63ea051284e36cf59.zip
sys-devel/clang-runtime: Bump to 13.0.0rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-13.0.0_rc1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-13.0.0_rc1.ebuild b/sys-devel/clang-runtime/clang-runtime-13.0.0_rc1.ebuild
new file mode 100644
index 000000000000..218cdb1426f6
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-13.0.0_rc1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"