summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-01 14:36:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-01 15:26:59 +0200
commitea25e70abf11525932e045ecddc06110a763e578 (patch)
tree0277f60be8c3545ea2472e66502206fc39a43191 /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 13.0.0 (final) (diff)
downloadgentoo-ea25e70abf11525932e045ecddc06110a763e578.tar.gz
gentoo-ea25e70abf11525932e045ecddc06110a763e578.tar.bz2
gentoo-ea25e70abf11525932e045ecddc06110a763e578.zip
sys-devel/clang-runtime: Bump to 13.0.0 (final)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-13.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-13.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-13.0.0.ebuild
new file mode 100644
index 000000000000..b3f915df904c
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-13.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"