summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-06 08:20:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-06 08:20:14 +0200
commit64b09b6db494dccc609b94f8492e4e85e21aed8f (patch)
tree7dae2a9576926435c2b735a379fbcf8332621ab4 /sys-devel/clang/clang-11.0.0.9999.ebuild
parentdev-python/django: Redo bash-completion patch for 3.0.6 (diff)
downloadgentoo-64b09b6db494dccc609b94f8492e4e85e21aed8f.tar.gz
gentoo-64b09b6db494dccc609b94f8492e4e85e21aed8f.tar.bz2
gentoo-64b09b6db494dccc609b94f8492e4e85e21aed8f.zip
sys-devel/clang: Do not install clang-tidy-headers after all
Stop installing clang-tidy-headers since no libraries are installed corresponding to these headers. Closes: https://bugs.gentoo.org/720774 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang/clang-11.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang/clang-11.0.0.9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-devel/clang/clang-11.0.0.9999.ebuild b/sys-devel/clang/clang-11.0.0.9999.ebuild
index 2f9362c815a1..ff2421448499 100644
--- a/sys-devel/clang/clang-11.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-11.0.0.9999.ebuild
@@ -107,6 +107,10 @@ check_distribution_components() {
clang*|findAllSymbols)
continue
;;
+ # headers for clang-tidy static library
+ clang-tidy-headers)
+ continue
+ ;;
esac
all_targets+=( "${l}" )
@@ -181,7 +185,6 @@ get_distribution_components() {
clang-query
clang-reorder-fields
clang-tidy
- clang-tidy-headers
clangd
find-all-symbols
modularize