summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-01-09 20:32:48 +0100
committerMichał Górny <mgorny@gentoo.org>2019-01-09 21:30:46 +0100
commit0b2dd924196f59d5f05373320a5f753190a533c1 (patch)
tree7ea78e9a98af79776b1e44e9cd1bd269864b01a1 /sys-devel/clang
parentsci-mathematics/z3: Enable multilib support (diff)
downloadgentoo-0b2dd924196f59d5f05373320a5f753190a533c1.tar.gz
gentoo-0b2dd924196f59d5f05373320a5f753190a533c1.tar.bz2
gentoo-0b2dd924196f59d5f05373320a5f753190a533c1.zip
sys-devel/clang: Update z3 option name
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 9e95b51eaf98..98b025974053 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -137,7 +137,7 @@ multilib_src_configure() {
-DCLANG_ENABLE_ARCMT=$(usex static-analyzer)
-DCLANG_ENABLE_STATIC_ANALYZER=$(usex static-analyzer)
# z3 is not multilib-friendly
- -DCLANG_ANALYZER_BUILD_Z3=$(multilib_native_usex z3)
+ -DCLANG_ANALYZER_ENABLE_Z3_SOLVER=$(multilib_native_usex z3)
)
use test && mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"