summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-02-26 18:09:32 +0100
committerFabian Groffen <grobian@gentoo.org>2017-02-26 18:10:06 +0100
commit6008cdc6c2b8e4e5e1ff163b9b649ad9ffbe08fe (patch)
tree2723b8609f2e5dfe44c32133aaaf2719974903c2 /sys-devel/gdb-apple/gdb-apple-563.ebuild
parentdev-util/debhelper: ppc stable (bug 593768). (diff)
downloadgentoo-6008cdc6c2b8e4e5e1ff163b9b649ad9ffbe08fe.tar.gz
gentoo-6008cdc6c2b8e4e5e1ff163b9b649ad9ffbe08fe.tar.bz2
gentoo-6008cdc6c2b8e4e5e1ff163b9b649ad9ffbe08fe.zip
sys-devel/gdb-apples: cleanup, bump ebuilds to EAPI=6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-devel/gdb-apple/gdb-apple-563.ebuild')
-rw-r--r--sys-devel/gdb-apple/gdb-apple-563.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-563.ebuild b/sys-devel/gdb-apple/gdb-apple-563.ebuild
deleted file mode 100644
index 5dc323555528..000000000000
--- a/sys-devel/gdb-apple/gdb-apple-563.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Apple branch of the GNU Debugger, Xcode 2.4"
-HOMEPAGE="https://sourceware.org/gdb/"
-SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${PV}.tar.gz"
-
-LICENSE="APSL-2 GPL-2"
-SLOT="0"
-
-KEYWORDS="~ppc-macos ~x86-macos"
-
-IUSE="nls"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2
- =dev-db/sqlite-3*"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/gdb-${PV}/src
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-darwin7.patch
- epatch "${FILESDIR}"/${P}-no-64bit.patch
- epatch "${FILESDIR}"/${PN}-768-texinfo.patch
-
- # for FSF gcc / gcc-apple:42
- sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
-}
-
-src_configure() {
- replace-flags -O? -O2
- econf \
- --disable-werror \
- $(use_enable nls) \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
- rm -r "${D}"/nukeme || die
- rm -Rf "${ED}"/usr/${CHOST} || die
- mv "${ED}"/usr/bin/gdb "${ED}"/
- rm -f "${ED}"/usr/bin/*
- mv "${ED}"/gdb "${ED}"/usr/bin/
-}