summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 10:32:50 -0500
committerMikle Kolyada <zlogene@gentoo.org>2018-04-23 17:53:16 +0300
commit723fdafd10de6568b6348ad7233d3dc26757995e (patch)
tree34ead4b00fe66e6b8eea83bec1ba639adfb74b97 /sys-devel/gdb-apple
parentsys-apps/baselayout-prefix: epatch->eapply (diff)
downloadgentoo-723fdafd10de6568b6348ad7233d3dc26757995e.tar.gz
gentoo-723fdafd10de6568b6348ad7233d3dc26757995e.tar.bz2
gentoo-723fdafd10de6568b6348ad7233d3dc26757995e.zip
sys-devel/gdb-apple: epatch->PATCHES=()
Also reworked patches to be -p1 (tricky due to the wierd ${S} setting. Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-devel/gdb-apple')
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1461-darwin8.patch28
-rw-r--r--sys-devel/gdb-apple/files/gdb-apple-1461-dyld-info.patch4
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1461.ebuild18
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1752.ebuild20
-rw-r--r--sys-devel/gdb-apple/gdb-apple-768-r1.ebuild15
-rw-r--r--sys-devel/gdb-apple/gdb-apple-966.ebuild21
6 files changed, 56 insertions, 50 deletions
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1461-darwin8.patch b/sys-devel/gdb-apple/files/gdb-apple-1461-darwin8.patch
index 40ef761e8f70..c89c82a0d18c 100644
--- a/sys-devel/gdb-apple/files/gdb-apple-1461-darwin8.patch
+++ b/sys-devel/gdb-apple/files/gdb-apple-1461-darwin8.patch
@@ -1,5 +1,5 @@
---- gdb-1461.2/src/gdb/macosx/macosx-nat-inferior.c
-+++ gdb-1461.2/src/gdb/macosx/macosx-nat-inferior.c
+--- a/gdb/macosx/macosx-nat-inferior.c
++++ b/gdb/macosx/macosx-nat-inferior.c
@@ -60,13 +60,17 @@
#include <sys/sysctl.h>
#include <sys/proc.h>
@@ -18,8 +18,8 @@
#include "macosx-nat-dyld.h"
#include "macosx-nat-inferior.h"
---- gdb-1461.2/src/gdb/macosx/macosx-nat-info.c
-+++ gdb-1461.2/src/gdb/macosx/macosx-nat-info.c
+--- a/gdb/macosx/macosx-nat-info.c
++++ b/gdb/macosx/macosx-nat-info.c
@@ -45,6 +45,22 @@
#include "macosx-nat-inferior.h"
#include "macosx-nat-inferior-debug.h"
@@ -43,8 +43,8 @@
extern macosx_inferior_status *macosx_status;
#define CHECK_ARGS(what, args) \
---- gdb-1461.2/src/gdb/macosx/macosx-nat-infthread.c
-+++ gdb-1461.2/src/gdb/macosx/macosx-nat-infthread.c
+--- a/gdb/macosx/macosx-nat-infthread.c
++++ b/gdb/macosx/macosx-nat-infthread.c
@@ -36,8 +36,10 @@
#include <sys/dir.h>
#include <inttypes.h>
@@ -56,8 +56,8 @@
#include "macosx-nat-inferior.h"
#include "macosx-nat-inferior-util.h"
---- gdb-1461.2/src/gdb/macosx/macosx-tdep.c
-+++ gdb-1461.2/src/gdb/macosx/macosx-tdep.c
+--- a/gdb/macosx/macosx-tdep.c
++++ b/gdb/macosx/macosx-tdep.c
@@ -63,7 +63,6 @@
#include "gdbcore.h"
@@ -66,8 +66,8 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <sys/param.h>
---- gdb-1461.2/src/gdb/remote.c
-+++ gdb-1461.2/src/gdb/remote.c
+--- a/gdb/remote.c
++++ b/gdb/remote.c
@@ -62,7 +62,6 @@
#include "macosx-nat-dyld.h"
#include "macosx-nat-dyld-process.h"
@@ -90,8 +90,8 @@
}
static void
---- gdb-1461.2/src/gdb/symfile.c
-+++ gdb-1461.2/src/gdb/symfile.c
+--- a/gdb/symfile.c
++++ b/gdb/symfile.c
@@ -67,7 +67,6 @@
#include <ctype.h>
#include <time.h>
@@ -100,8 +100,8 @@
#include <sys/mman.h>
---- gdb-1461.2/src/gdb/utils.c
-+++ gdb-1461.2/src/gdb/utils.c
+--- a/gdb/utils.c
++++ b/gdb/utils.c
@@ -27,7 +27,6 @@
#include "gdb_string.h"
#include "event-top.h"
diff --git a/sys-devel/gdb-apple/files/gdb-apple-1461-dyld-info.patch b/sys-devel/gdb-apple/files/gdb-apple-1461-dyld-info.patch
index 75b910432278..fb9ca9c74115 100644
--- a/sys-devel/gdb-apple/files/gdb-apple-1461-dyld-info.patch
+++ b/sys-devel/gdb-apple/files/gdb-apple-1461-dyld-info.patch
@@ -1,8 +1,8 @@
If dyld-info is not available, don't try to compile unreachable code
using it either.
---- gdb-1461.2/src/gdb/macosx/macosx-nat-dyld.c
-+++ gdb-1461.2/src/gdb/macosx/macosx-nat-dyld.c
+--- a/gdb/macosx/macosx-nat-dyld.c
++++ b/gdb/macosx/macosx-nat-dyld.c
@@ -731,7 +731,7 @@
{
#if !defined (TASK_DYLD_INFO) || !defined (NM_NEXTSTEP)
diff --git a/sys-devel/gdb-apple/gdb-apple-1461.ebuild b/sys-devel/gdb-apple/gdb-apple-1461.ebuild
index 39484c62c317..7127e61d2445 100644
--- a/sys-devel/gdb-apple/gdb-apple-1461.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-1461.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit eutils flag-o-matic
@@ -24,16 +24,18 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${APPLE_PV}/src
+PATCHES=(
+ "${FILESDIR}"/${PN}-no-global-gdbinit.patch
+ "${FILESDIR}"/${PN}-768-texinfo.patch
+ "${FILESDIR}"/${P}-dyld-info.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-no-global-gdbinit.patch
- epatch "${FILESDIR}"/${PN}-768-texinfo.patch
- epatch "${FILESDIR}"/${P}-dyld-info.patch
- [[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${P}-darwin8.patch
+ default
+ [[ ${CHOST} == *-darwin8 ]] && eapply "${FILESDIR}"/${P}-darwin8.patch
# for FSF gcc / gcc-apple:42
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
-
- eapply_user
}
src_configure() {
diff --git a/sys-devel/gdb-apple/gdb-apple-1752.ebuild b/sys-devel/gdb-apple/gdb-apple-1752.ebuild
index 6a6d6a5c511c..f374628fb7d5 100644
--- a/sys-devel/gdb-apple/gdb-apple-1752.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-1752.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit eutils flag-o-matic
@@ -24,14 +24,16 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${APPLE_PV}/src
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-no-global-gdbinit.patch
- epatch "${FILESDIR}"/${PN}-768-texinfo.patch
- epatch "${FILESDIR}"/${PN}-1518-darwin8-9.patch
- epatch "${FILESDIR}"/${PN}-1705-darwin8-10.patch
- [[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1518-darwin8.patch
+PATCHES=(
+ "${FILESDIR}"/${PN}-no-global-gdbinit.patch
+ "${FILESDIR}"/${PN}-768-texinfo.patch
+ "${FILESDIR}"/${PN}-1518-darwin8-9.patch
+ "${FILESDIR}"/${PN}-1705-darwin8-10.patch
+)
- eapply_user
+src_prepare() {
+ default
+ [[ ${CHOST} == *-darwin8 ]] && eapply "${FILESDIR}"/${PN}-1518-darwin8.patch
}
src_configure() {
diff --git a/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild b/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
index 1206ecb0b60a..e9f84fc168a6 100644
--- a/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit eutils flag-o-matic
@@ -23,14 +23,15 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_prepare() {
- epatch "${FILESDIR}"/${P}-texinfo.patch
- epatch "${FILESDIR}"/${P}-darwin-arch.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-texinfo.patch
+ "${FILESDIR}"/${P}-darwin-arch.patch
+)
+src_prepare() {
+ default
# for FSF gcc / gcc-apple:42
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
-
- eapply_user
}
src_configure() {
diff --git a/sys-devel/gdb-apple/gdb-apple-966.ebuild b/sys-devel/gdb-apple/gdb-apple-966.ebuild
index 15017df485c8..7ffb29ce62ac 100644
--- a/sys-devel/gdb-apple/gdb-apple-966.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-966.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit eutils flag-o-matic
@@ -23,17 +23,18 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-768-texinfo.patch
- epatch "${FILESDIR}"/${PN}-768-darwin-arch.patch
- epatch "${FILESDIR}"/${PN}-962-darwin8.patch
- epatch "${FILESDIR}"/${PN}-962-darwin64.patch
- epatch "${FILESDIR}"/${PN}-962-demangle.patch
+PATCHES=(
+ "${FILESDIR}"/${PN}-768-texinfo.patch
+ "${FILESDIR}"/${PN}-768-darwin-arch.patch
+ "${FILESDIR}"/${PN}-962-darwin8.patch
+ "${FILESDIR}"/${PN}-962-darwin64.patch
+ "${FILESDIR}"/${PN}-962-demangle.patch
+)
+src_prepare() {
+ default
# for FSF gcc / gcc-apple:42
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
-
- eapply_user
}
src_configure() {