summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-17 09:42:08 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-17 14:03:30 +0100
commit1799e4a1429d7160488e01cb6edb9e0a64564bab (patch)
treebb91416c24c5d429d440907cc32a3ff3e8225796 /sys-devel/llvm-common/llvm-common-11.1.0.ebuild
parentdev-db/sqlitebrowser: version bump and adoption (diff)
downloadgentoo-1799e4a1429d7160488e01cb6edb9e0a64564bab.tar.gz
gentoo-1799e4a1429d7160488e01cb6edb9e0a64564bab.tar.bz2
gentoo-1799e4a1429d7160488e01cb6edb9e0a64564bab.zip
sys-devel/llvm-common: Bump to 11.1.0 (final)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-11.1.0.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-11.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-11.1.0.ebuild b/sys-devel/llvm-common/llvm-common-11.1.0.ebuild
new file mode 100644
index 000000000000..c332f7dbbd1d
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-11.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}