summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-22 15:43:14 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-22 17:11:50 +0200
commit11d093e4ec16f42e733d605dccf3100d4bb435ba (patch)
tree430bb5398c01766b2874e1226a187749ffa98f69 /sys-devel/llvm/files/llvm-3.9-llvm-config.patch
parentsys-devel/clang: Enable stand-alone builds against sys-devel/llvm (diff)
downloadgentoo-11d093e4ec16f42e733d605dccf3100d4bb435ba.tar.gz
gentoo-11d093e4ec16f42e733d605dccf3100d4bb435ba.tar.bz2
gentoo-11d093e4ec16f42e733d605dccf3100d4bb435ba.zip
sys-devel/llvm: Group all patches by newest version applicable
Diffstat (limited to 'sys-devel/llvm/files/llvm-3.9-llvm-config.patch')
-rw-r--r--sys-devel/llvm/files/llvm-3.9-llvm-config.patch67
1 files changed, 0 insertions, 67 deletions
diff --git a/sys-devel/llvm/files/llvm-3.9-llvm-config.patch b/sys-devel/llvm/files/llvm-3.9-llvm-config.patch
deleted file mode 100644
index a1b0be92d337..000000000000
--- a/sys-devel/llvm/files/llvm-3.9-llvm-config.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 93133d777fd4c9d5e0f0cc563927f303f9527159 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 20 Aug 2016 23:47:41 +0200
-Subject: [PATCH] llvm-config: Clean up exported values, update for shared
- linking
-
-Gentoo-specific fixup for llvm-config, including:
-- wiping build-specific CFLAGS, CXXFLAGS,
-- updating library suffixes for shared libs,
-- wiping --system-libs for shared linking,
-- making --obj-root and --src-root return invalid path (/dev/null),
-- making --build-mode return "Release" rather than "Gentoo".
-
-Thanks to Steven Newbury for the initial patch.
-
-Bug: https://bugs.gentoo.org/565358
-Bug: https://bugs.gentoo.org/501684
----
- tools/llvm-config/CMakeLists.txt | 11 ++++++++---
- tools/llvm-config/llvm-config.cpp | 15 ++++++++++++---
- 2 files changed, 20 insertions(+), 6 deletions(-)
-
-diff --git a/tools/llvm-config/CMakeLists.txt b/tools/llvm-config/CMakeLists.txt
-index 744fa4e..593788a 100644
---- a/tools/llvm-config/CMakeLists.txt
-+++ b/tools/llvm-config/CMakeLists.txt
-@@ -34,4 +34,8 @@ set(LLVM_OBJ_ROOT ${LLVM_BINARY_DIR})
- set(LLVM_CPPFLAGS "${CMAKE_CPP_FLAGS} ${CMAKE_CPP_FLAGS_${uppercase_CMAKE_BUILD_TYPE}} ${LLVM_DEFINITIONS}")
--set(LLVM_CFLAGS "${CMAKE_C_FLAGS} ${CMAKE_C_FLAGS_${uppercase_CMAKE_BUILD_TYPE}} ${LLVM_DEFINITIONS}")
--set(LLVM_CXXFLAGS "${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_${uppercase_CMAKE_BUILD_TYPE}} ${COMPILE_FLAGS} ${LLVM_DEFINITIONS}")
-+# Just use CMAKE_CPP_FLAGS for CFLAGS and CXXFLAGS, otherwise compiler
-+# specific flags will be set when we don't know what compiler will be used
-+# with external project utilising llvm-config. C++ Standard is required.
-+# TODO: figure out if we can remove -std=c++11 and move it to revdeps.
-+set(LLVM_CFLAGS "${CMAKE_CPP_FLAGS} ${CMAKE_C_FLAGS_${uppercase_CMAKE_BUILD_TYPE}} ${LLVM_DEFINITIONS}")
-+set(LLVM_CXXFLAGS "${CMAKE_CPP_FLAGS} -std=c++11 ${CMAKE_CXX_FLAGS_${uppercase_CMAKE_BUILD_TYPE}} ${LLVM_DEFINITIONS}")
- set(LLVM_BUILD_SYSTEM cmake)
-@@ -48,3 +52,4 @@ set(LLVM_LDFLAGS "${CMAKE_CXX_LINK_FLAGS}")
- set(LLVM_BUILDMODE ${CMAKE_BUILD_TYPE})
--set(LLVM_SYSTEM_LIBS ${SYSTEM_LIBS})
-+# We don't do static libs, so we don't need to supply any system-libs
-+set(LLVM_SYSTEM_LIBS "")
- if(BUILD_SHARED_LIBS)
-diff --git a/tools/llvm-config/llvm-config.cpp b/tools/llvm-config/llvm-config.cpp
-index c63733f..ead11b9 100644
---- a/tools/llvm-config/llvm-config.cpp
-+++ b/tools/llvm-config/llvm-config.cpp
-@@ -524,3 +524,4 @@ int main(int argc, char **argv) {
- } else if (Arg == "--build-mode") {
-- OS << build_mode << '\n';
-+ // force Release since we force non-standard Gentoo build mode
-+ OS << "Release" << '\n';
- } else if (Arg == "--assertion-mode") {
-@@ -540,5 +540,9 @@ int main(int argc, char **argv) {
- } else if (Arg == "--obj-root") {
- OS << ActivePrefix << '\n';
- } else if (Arg == "--src-root") {
-- OS << LLVM_SRC_ROOT << '\n';
-+ if (IsInDevelopmentTree) {
-+ OS << LLVM_SRC_ROOT << '\n';
-+ } else {
-+ OS << "/dev/null\n";
-+ }
- } else if (Arg == "--link-shared") {
---
-2.9.3
-