summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-23 20:33:00 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-23 22:36:07 +0100
commit4ddd0a5aaa862839547bfedf459acb326fa977e8 (patch)
treeb85a426dbe570a05420829a21a140601fc7ac0ec /sys-devel/llvm/llvm-9999.ebuild
parentmedia-tv/kodi: add support for net-libs/shairplay (diff)
downloadgentoo-4ddd0a5aaa862839547bfedf459acb326fa977e8.tar.gz
gentoo-4ddd0a5aaa862839547bfedf459acb326fa977e8.tar.bz2
gentoo-4ddd0a5aaa862839547bfedf459acb326fa977e8.zip
sys-devel/llvm: Force x86 CHOST to i386-* for compiler-rt compat
Force x86 CHOST value to be i386-* since clang uses the exact arch value to find compiler-rt libraries, and our compiler-rt libraries are named 'i386' unconditionally. It should still be able to find gcc install by using alternate triple aliases.
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index a66f1e10dc84..49c65e2b36d0 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -154,7 +154,10 @@ multilib_src_configure() {
-DWITH_POLLY=OFF # TODO
- -DLLVM_HOST_TRIPLE="${CHOST}"
+ # 'normalize' x86 triples to i386-* since this is the name used
+ # by compiler-rt libraries.
+ # remove this when https://reviews.llvm.org/D26796 is merged
+ -DLLVM_HOST_TRIPLE="${CHOST/#i[4-9]86-/i386-}"
-DFFI_INCLUDE_DIR="${ffi_cflags#-I}"
-DFFI_LIBRARY_DIR="${ffi_ldflags#-L}"