summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-12-05 17:32:24 +0100
committerMichał Górny <mgorny@gentoo.org>2015-12-05 17:34:43 +0100
commit6b4c6da6ce3123ba26ff0c42d8ae0fdacebfda9b (patch)
treeb3378f4ff2d777ae1c037c731146d3b4e224aa80 /sys-devel/llvm/llvm-9999.ebuild
parentprofiles/updates: grass slotmove Malformed update entry repaired (diff)
downloadgentoo-6b4c6da6ce3123ba26ff0c42d8ae0fdacebfda9b.tar.gz
gentoo-6b4c6da6ce3123ba26ff0c42d8ae0fdacebfda9b.tar.bz2
gentoo-6b4c6da6ce3123ba26ff0c42d8ae0fdacebfda9b.zip
sys-devel/llvm: Set libomp as default OpenMP provider in -9999, #562990
Use libomp as default OpenMP provider rather than libgomp because the support for the latter is unable to find omp.h without explicit -I, and provides syntax checking only. Bug: https://bugs.gentoo.org/show_bug.cgi?id=562990
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index e65e57368880..2f8afe756340 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -254,6 +254,9 @@ multilib_src_configure() {
if use clang; then
mycmakeargs+=(
-DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex !xml)
+ # libgomp support fails to find headers without explicit -I
+ # furthermore, it provides only syntax checking
+ -DCLANG_DEFAULT_OPENMP_RUNTIME=libomp
)
fi
@@ -481,8 +484,7 @@ multilib_src_install_all() {
}
pkg_postinst() {
- if use clang; then
- elog "To enable OpenMP support in clang, install sys-libs/libomp"
- elog "and use the '-fopenmp=libomp' command line option"
+ if use clang && ! has_version 'sys-libs/libomp'; then
+ elog "To enable OpenMP support in clang, install sys-libs/libomp."
fi
}