summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-09-02 11:48:50 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-09-02 11:49:00 +0200
commit9ff44a9a9eaa6b21f61320cb9d8d0781dcea3acf (patch)
treebd2f8626ff481cb61f6869465b7d8d76079f71d2 /sys-devel/llvm/llvm-9999.ebuild
parentsys-devel/clang: bump to final release (diff)
downloadgentoo-9ff44a9a9eaa6b21f61320cb9d8d0781dcea3acf.tar.gz
gentoo-9ff44a9a9eaa6b21f61320cb9d8d0781dcea3acf.tar.bz2
gentoo-9ff44a9a9eaa6b21f61320cb9d8d0781dcea3acf.zip
sys-devel/llvm: bump to final release
Also fixes WX sections and multilib-strict install forocaml bindings Both fixes from gienah, bugs #421527 and #559134 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 1681622e5329..325a857ef1d6 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -155,6 +155,8 @@ src_unpack() {
src_prepare() {
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
+ # Fix libdir for ocaml bindings install, bug #559134
+ epatch "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-multilib.patch
# Make it possible to override Sphinx HTML install dirs
# https://llvm.org/bugs/show_bug.cgi?id=23780
@@ -190,6 +192,11 @@ src_prepare() {
# https://llvm.org/bugs/show_bug.cgi?id=23793
epatch "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+ # Fix WX sections, bug #421527
+ find "${S}"/projects/compiler-rt/lib/builtins -type f -name \*.S -exec sed \
+ -e '$a\\n#if defined(__linux__) && defined(__ELF__)\n.section .note.GNU-stack,"",%progbits\n#endif' \
+ -i {} \; || die
+
# Workaround bug #553416 until upstream fixes it
epatch "${FILESDIR}"/clang-3.7-strip_doc_refs.patch
fi