summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-19 10:52:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-19 10:52:49 +0200
commita564bdff02df5a878ddf90988538a457596443e1 (patch)
tree9a00e965eff177c3a0535abfdabe5d1551370d76 /sys-devel/llvm/llvm-9999.ebuild
parentdev-ruby/rb-inotify: add 0.9.10 (diff)
downloadgentoo-a564bdff02df5a878ddf90988538a457596443e1.tar.gz
gentoo-a564bdff02df5a878ddf90988538a457596443e1.tar.bz2
gentoo-a564bdff02df5a878ddf90988538a457596443e1.zip
sys-devel/llvm: Fix path to llvm-tblgen when cross compiling.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 545cfbbcb49c..99121e917a09 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -154,11 +154,12 @@ multilib_src_configure() {
fi
if tc-is-cross-compiler; then
- [[ -x "/usr/bin/llvm-tblgen" ]] \
- || die "/usr/bin/llvm-tblgen not found or usable"
+ local tblgen="${EPREFIX}/usr/lib/llvm/${SLOT}/bin/llvm-tblgen"
+ [[ -x "${tblgen}" ]] \
+ || die "${tblgen} not found or usable"
mycmakeargs+=(
-DCMAKE_CROSSCOMPILING=ON
- -DLLVM_TABLEGEN=/usr/bin/llvm-tblgen
+ -DLLVM_TABLEGEN="${tblgen}"
)
fi