summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-03-28 23:25:58 +0200
committerMichał Górny <mgorny@gentoo.org>2016-03-28 23:31:31 +0200
commit53b557d74a46377d01187116dc50c8509e992f10 (patch)
treeb4951f545a7169127686095bd5296f91bf4a6d06 /sys-devel/llvm
parentsys-devel/llvm: Update patches for the live ebuild (diff)
downloadgentoo-53b557d74a46377d01187116dc50c8509e992f10.tar.gz
gentoo-53b557d74a46377d01187116dc50c8509e992f10.tar.bz2
gentoo-53b557d74a46377d01187116dc50c8509e992f10.zip
sys-devel/llvm: Backport EAPI=6 changes to 3.7.1-r1 and 3.8.0-r1
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/files/clang-3.4-darwin_prefix-include-paths.patch4
-rw-r--r--sys-devel/llvm/files/cmake/llvm-3.7.0-lldb_tinfo.patch4
-rw-r--r--sys-devel/llvm/llvm-3.7.1-r1.ebuild56
-rw-r--r--sys-devel/llvm/llvm-3.8.0-r1.ebuild46
4 files changed, 43 insertions, 67 deletions
diff --git a/sys-devel/llvm/files/clang-3.4-darwin_prefix-include-paths.patch b/sys-devel/llvm/files/clang-3.4-darwin_prefix-include-paths.patch
index f5f1d9e387e9..ed332f3f68af 100644
--- a/sys-devel/llvm/files/clang-3.4-darwin_prefix-include-paths.patch
+++ b/sys-devel/llvm/files/clang-3.4-darwin_prefix-include-paths.patch
@@ -1,5 +1,5 @@
---- tools/clang/lib/Frontend/InitHeaderSearch.cpp
-+++ tools/clang/lib/Frontend/InitHeaderSearch.cpp
+--- a/tools/clang/lib/Frontend/InitHeaderSearch.cpp
++++ b/tools/clang/lib/Frontend/InitHeaderSearch.cpp
@@ -233,6 +233,7 @@
case llvm::Triple::Bitrig:
break;
diff --git a/sys-devel/llvm/files/cmake/llvm-3.7.0-lldb_tinfo.patch b/sys-devel/llvm/files/cmake/llvm-3.7.0-lldb_tinfo.patch
index c0f3a5ff3c8a..626498c57eea 100644
--- a/sys-devel/llvm/files/cmake/llvm-3.7.0-lldb_tinfo.patch
+++ b/sys-devel/llvm/files/cmake/llvm-3.7.0-lldb_tinfo.patch
@@ -1,5 +1,5 @@
---- tools/lldb/cmake/LLDBDependencies.cmake 2015/09/16 20:13:53 247841
-+++ tools/lldb/cmake/LLDBDependencies.cmake 2015/09/16 20:14:01 247842
+--- a/tools/lldb/cmake/LLDBDependencies.cmake 2015/09/16 20:13:53 247841
++++ b/tools/lldb/cmake/LLDBDependencies.cmake 2015/09/16 20:14:01 247842
@@ -141,6 +141,9 @@
endif()
if (NOT LLDB_DISABLE_CURSES)
diff --git a/sys-devel/llvm/llvm-3.7.1-r1.ebuild b/sys-devel/llvm/llvm-3.7.1-r1.ebuild
index 5ae3bc64414c..7bd5432dd533 100644
--- a/sys-devel/llvm/llvm-3.7.1-r1.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
PYTHON_COMPAT=( python2_7 )
@@ -111,18 +111,6 @@ pkg_pretend() {
local CHECKREQS_DISK_BUILD=${build_size}M
check-reqs_pkg_pretend
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- echo 'int main() {return 0;}' > "${T}"/test.cxx || die
- ebegin "Trying to build a C++11 test program"
- if ! $(tc-getCXX) -std=c++11 -o /dev/null "${T}"/test.cxx; then
- eerror "LLVM-${PV} requires C++11-capable C++ compiler. Your current compiler"
- eerror "does not seem to support -std=c++11 option. Please upgrade your compiler"
- eerror "to gcc-4.7 or an equivalent version supporting C++11."
- die "Currently active compiler does not support -std=c++11"
- fi
- eend ${?}
- fi
}
pkg_setup() {
@@ -151,21 +139,21 @@ src_prepare() {
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
# Fix libdir for ocaml bindings install, bug #559134
- epatch "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-multilib.patch
+ eapply "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-multilib.patch
# Do not build/install ocaml docs with USE=-doc, bug #562008
- epatch "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-build_doc.patch
+ eapply "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-build_doc.patch
# Make it possible to override Sphinx HTML install dirs
# https://llvm.org/bugs/show_bug.cgi?id=23780
- epatch "${FILESDIR}"/cmake/0002-cmake-Support-overriding-Sphinx-HTML-doc-install-dir.patch
+ eapply "${FILESDIR}"/cmake/0002-cmake-Support-overriding-Sphinx-HTML-doc-install-dir.patch
# Prevent race conditions with parallel Sphinx runs
# https://llvm.org/bugs/show_bug.cgi?id=23781
- epatch "${FILESDIR}"/cmake/0003-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+ eapply "${FILESDIR}"/cmake/0003-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
- epatch "${FILESDIR}"/cmake/0004-cmake-Do-not-install-libgtest.patch
+ eapply "${FILESDIR}"/cmake/0004-cmake-Do-not-install-libgtest.patch
# Fix llvm-config for shared linking, sane flags and return values
# in order:
@@ -175,24 +163,24 @@ src_prepare() {
# - backported r260343 that fixes cross-compilation
# combination of backported upstream r252532 with our patch
# https://bugs.gentoo.org/show_bug.cgi?id=565358
- epatch "${FILESDIR}"/llvm-3.7.1-llvm-config-0.patch
- epatch "${FILESDIR}"/llvm-3.7.1-llvm-config-1.patch
- epatch "${FILESDIR}"/llvm-3.7.1-llvm-config-2.patch
- epatch "${FILESDIR}"/llvm-3.7.1-llvm-config-3.patch
+ eapply "${FILESDIR}"/llvm-3.7.1-llvm-config-0.patch
+ eapply "${FILESDIR}"/llvm-3.7.1-llvm-config-1.patch
+ eapply "${FILESDIR}"/llvm-3.7.1-llvm-config-2.patch
+ eapply "${FILESDIR}"/llvm-3.7.1-llvm-config-3.patch
# Fix msan with newer kernels, #569894
- epatch "${FILESDIR}"/llvm-3.7-msan-fix.patch
+ eapply "${FILESDIR}"/llvm-3.7-msan-fix.patch
# disable use of SDK on OSX, bug #568758
sed -i -e 's/xcrun/false/' utils/lit/lit/util.py || die
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- epatch "${FILESDIR}"/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
+ eapply "${FILESDIR}"/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/clang-3.6-gentoo-install.patch
+ eapply "${FILESDIR}"/clang-3.6-gentoo-install.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
+ eapply "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
sed -i -e "s^@EPREFIX@^${EPREFIX}^" \
@@ -200,22 +188,22 @@ src_prepare() {
# Install clang runtime into /usr/lib/clang
# https://llvm.org/bugs/show_bug.cgi?id=23792
- epatch "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix.patch
- epatch "${FILESDIR}"/cmake/compiler-rt-0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
+ eapply "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix.patch
+ eapply "${FILESDIR}"/cmake/compiler-rt-0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
# Do not force -march flags on arm platforms
# https://bugs.gentoo.org/show_bug.cgi?id=562706
- epatch "${FILESDIR}"/cmake/${PN}-3.7.0-compiler_rt_arm_march_flags.patch
+ eapply "${FILESDIR}"/cmake/${PN}-3.7.0-compiler_rt_arm_march_flags.patch
# Make it possible to override CLANG_LIBDIR_SUFFIX
# (that is used only to find LLVMgold.so)
# https://llvm.org/bugs/show_bug.cgi?id=23793
- epatch "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+ eapply "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
pushd projects/compiler-rt >/dev/null || die
# Fix msan with newer kernels, compiler-rt part, #569894
- epatch "${FILESDIR}"/compiler-rt-3.7-msan-fix.patch
+ eapply "${FILESDIR}"/compiler-rt-3.7-msan-fix.patch
# Fix WX sections, bug #421527
find lib/builtins -type f -name '*.S' -exec sed \
@@ -232,17 +220,17 @@ src_prepare() {
-i tools/lldb/scripts/Python/modules/CMakeLists.txt || die
# Fix Python paths, bugs #562436 and #562438
- epatch "${FILESDIR}"/${PN}-3.7-lldb_python.patch
+ eapply "${FILESDIR}"/${PN}-3.7-lldb_python.patch
sed -e "s/GENTOO_LIBDIR/$(get_libdir)/" \
-i tools/lldb/scripts/Python/finishSwigPythonLLDB.py || die
# Fix build with ncurses[tinfo], #560474
# http://llvm.org/viewvc/llvm-project?view=revision&revision=247842
- epatch "${FILESDIR}"/cmake/${PN}-3.7.0-lldb_tinfo.patch
+ eapply "${FILESDIR}"/cmake/${PN}-3.7.0-lldb_tinfo.patch
fi
# User patches
- epatch_user
+ eapply_user
python_setup
diff --git a/sys-devel/llvm/llvm-3.8.0-r1.ebuild b/sys-devel/llvm/llvm-3.8.0-r1.ebuild
index 41f1d792b92c..fe8e3e71e25d 100644
--- a/sys-devel/llvm/llvm-3.8.0-r1.ebuild
+++ b/sys-devel/llvm/llvm-3.8.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
PYTHON_COMPAT=( python2_7 )
@@ -112,18 +112,6 @@ pkg_pretend() {
local CHECKREQS_DISK_BUILD=${build_size}M
check-reqs_pkg_pretend
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- echo 'int main() {return 0;}' > "${T}"/test.cxx || die
- ebegin "Trying to build a C++11 test program"
- if ! $(tc-getCXX) -std=c++11 -o /dev/null "${T}"/test.cxx; then
- eerror "LLVM-${PV} requires C++11-capable C++ compiler. Your current compiler"
- eerror "does not seem to support -std=c++11 option. Please upgrade your compiler"
- eerror "to gcc-4.7 or an equivalent version supporting C++11."
- die "Currently active compiler does not support -std=c++11"
- fi
- eend ${?}
- fi
}
pkg_setup() {
@@ -152,41 +140,41 @@ src_prepare() {
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
# Fix libdir for ocaml bindings install, bug #559134
- epatch "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-multilib.patch
+ eapply "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-multilib.patch
# Do not build/install ocaml docs with USE=-doc, bug #562008
- epatch "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-build_doc.patch
+ eapply "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-build_doc.patch
# Make it possible to override Sphinx HTML install dirs
# https://llvm.org/bugs/show_bug.cgi?id=23780
- epatch "${FILESDIR}"/cmake/0002-cmake-Support-overriding-Sphinx-HTML-doc-install-dir.patch
+ eapply "${FILESDIR}"/cmake/0002-cmake-Support-overriding-Sphinx-HTML-doc-install-dir.patch
# Prevent race conditions with parallel Sphinx runs
# https://llvm.org/bugs/show_bug.cgi?id=23781
- epatch "${FILESDIR}"/cmake/0003-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+ eapply "${FILESDIR}"/cmake/0003-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
- epatch "${FILESDIR}"/cmake/0004-cmake-Do-not-install-libgtest.patch
+ eapply "${FILESDIR}"/cmake/0004-cmake-Do-not-install-libgtest.patch
# Allow custom cmake build types (like 'Gentoo')
- epatch "${FILESDIR}"/cmake/${PN}-3.8-allow_custom_cmake_build_types.patch
+ eapply "${FILESDIR}"/cmake/${PN}-3.8-allow_custom_cmake_build_types.patch
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358
- epatch "${FILESDIR}"/llvm-3.8-llvm-config.patch
+ eapply "${FILESDIR}"/llvm-3.8-llvm-config.patch
# Restore SOVERSIONs for shared libraries
# https://bugs.gentoo.org/show_bug.cgi?id=578392
- epatch "${FILESDIR}"/llvm-3.8-soversion.patch
+ eapply "${FILESDIR}"/llvm-3.8-soversion.patch
# disable use of SDK on OSX, bug #568758
sed -i -e 's/xcrun/false/' utils/lit/lit/util.py || die
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- epatch "${FILESDIR}"/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
+ eapply "${FILESDIR}"/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
+ eapply "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
sed -i -e "s^@EPREFIX@^${EPREFIX}^" \
@@ -194,17 +182,17 @@ src_prepare() {
# Install clang runtime into /usr/lib/clang
# https://llvm.org/bugs/show_bug.cgi?id=23792
- epatch "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch
- epatch "${FILESDIR}"/cmake/compiler-rt-0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
+ eapply "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch
+ eapply "${FILESDIR}"/cmake/compiler-rt-0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
# Do not force -march flags on arm platforms
# https://bugs.gentoo.org/show_bug.cgi?id=562706
- epatch "${FILESDIR}"/cmake/${PN}-3.8.0-compiler_rt_arm_march_flags.patch
+ eapply "${FILESDIR}"/cmake/${PN}-3.8.0-compiler_rt_arm_march_flags.patch
# Make it possible to override CLANG_LIBDIR_SUFFIX
# (that is used only to find LLVMgold.so)
# https://llvm.org/bugs/show_bug.cgi?id=23793
- epatch "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+ eapply "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
pushd projects/compiler-rt >/dev/null || die
@@ -222,11 +210,11 @@ src_prepare() {
sed -e 's/add_subdirectory(readline)/#&/' \
-i tools/lldb/scripts/Python/modules/CMakeLists.txt || die
# Do not install bundled six module
- epatch "${FILESDIR}"/${PN}-3.8-lldb_six.patch
+ eapply "${FILESDIR}"/${PN}-3.8-lldb_six.patch
fi
# User patches
- epatch_user
+ eapply_user
python_setup