summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-01-17 08:58:31 +0100
committerMichał Górny <mgorny@gentoo.org>2016-01-17 09:00:11 +0100
commit5993e7c35f0e828eebfc8d3932379a3c3399bba8 (patch)
tree5b234495f03a9771494aa97280e0c485a8082505 /sys-devel/llvm
parentprofiles/package.mask: sys-block/lsiutil issues resolved, still relevant to h... (diff)
downloadgentoo-5993e7c35f0e828eebfc8d3932379a3c3399bba8.tar.gz
gentoo-5993e7c35f0e828eebfc8d3932379a3c3399bba8.tar.bz2
gentoo-5993e7c35f0e828eebfc8d3932379a3c3399bba8.zip
sys-devel/llvm: Remove C++11 checks in -9999
Remove C++11 checks since the relevant gcc versions are stable for long enough already.
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild12
1 files changed, 0 insertions, 12 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 582064971ca..16c4d32ceac 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -101,18 +101,6 @@ pkg_pretend() {
local CHECKREQS_DISK_BUILD=${build_size}M
check-reqs_pkg_pretend
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- echo 'int main() {return 0;}' > "${T}"/test.cxx || die
- ebegin "Trying to build a C++11 test program"
- if ! $(tc-getCXX) -std=c++11 -o /dev/null "${T}"/test.cxx; then
- eerror "LLVM-${PV} requires C++11-capable C++ compiler. Your current compiler"
- eerror "does not seem to support -std=c++11 option. Please upgrade your compiler"
- eerror "to gcc-4.7 or an equivalent version supporting C++11."
- die "Currently active compiler does not support -std=c++11"
- fi
- eend ${?}
- fi
}
pkg_setup() {