summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-04 14:19:43 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-04 15:56:02 +0200
commit7d5d5224233fc71873b052f275bc2ffe45d22feb (patch)
tree5a460d115f3d3a4bfc7ce6d2760d509143dd63f2 /sys-devel/llvm
parentdev-python/pyparted: Version 3.11.1. (diff)
downloadgentoo-7d5d5224233fc71873b052f275bc2ffe45d22feb.tar.gz
gentoo-7d5d5224233fc71873b052f275bc2ffe45d22feb.tar.bz2
gentoo-7d5d5224233fc71873b052f275bc2ffe45d22feb.zip
sys-devel/llvm: Inform about opt-viewer scripts in postinst
Closes: https://bugs.gentoo.org/645040
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-5.0.1.ebuild9
-rw-r--r--sys-devel/llvm/llvm-6.0.0.ebuild9
-rw-r--r--sys-devel/llvm/llvm-6.0.9999.ebuild9
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild9
4 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-5.0.1.ebuild b/sys-devel/llvm/llvm-5.0.1.ebuild
index d705829ac8a..295cd485338 100644
--- a/sys-devel/llvm/llvm-5.0.1.ebuild
+++ b/sys-devel/llvm/llvm-5.0.1.ebuild
@@ -245,3 +245,12 @@ _EOF_
docompress "/usr/lib/llvm/${SLOT}/share/man"
}
+
+pkg_postinst() {
+ elog "You can find additional opt-viewer utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/opt-viewer"
+ elog "To use these scripts, you will need Python 2.7 along with the following"
+ elog "packages:"
+ elog " dev-python/pygments (for opt-viewer)"
+ elog " dev-python/pyyaml (for all of them)"
+}
diff --git a/sys-devel/llvm/llvm-6.0.0.ebuild b/sys-devel/llvm/llvm-6.0.0.ebuild
index 9e9f2c10509..162c216c1e6 100644
--- a/sys-devel/llvm/llvm-6.0.0.ebuild
+++ b/sys-devel/llvm/llvm-6.0.0.ebuild
@@ -251,3 +251,12 @@ _EOF_
docompress "/usr/lib/llvm/${SLOT}/share/man"
}
+
+pkg_postinst() {
+ elog "You can find additional opt-viewer utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/opt-viewer"
+ elog "To use these scripts, you will need Python 2.7 along with the following"
+ elog "packages:"
+ elog " dev-python/pygments (for opt-viewer)"
+ elog " dev-python/pyyaml (for all of them)"
+}
diff --git a/sys-devel/llvm/llvm-6.0.9999.ebuild b/sys-devel/llvm/llvm-6.0.9999.ebuild
index 6276ab4925a..b8768df35d5 100644
--- a/sys-devel/llvm/llvm-6.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-6.0.9999.ebuild
@@ -244,3 +244,12 @@ _EOF_
docompress "/usr/lib/llvm/${SLOT}/share/man"
}
+
+pkg_postinst() {
+ elog "You can find additional opt-viewer utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/opt-viewer"
+ elog "To use these scripts, you will need Python 2.7 along with the following"
+ elog "packages:"
+ elog " dev-python/pygments (for opt-viewer)"
+ elog " dev-python/pyyaml (for all of them)"
+}
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 414c82e01aa..e405d61283c 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -246,3 +246,12 @@ _EOF_
docompress "/usr/lib/llvm/${SLOT}/share/man"
}
+
+pkg_postinst() {
+ elog "You can find additional opt-viewer utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/opt-viewer"
+ elog "To use these scripts, you will need Python 2.7 along with the following"
+ elog "packages:"
+ elog " dev-python/pygments (for opt-viewer)"
+ elog " dev-python/pyyaml (for all of them)"
+}