summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-23 10:20:54 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-23 10:35:54 +0100
commitea7b6929b52c6571eadd5d6fd6fb3f8e266a3e1e (patch)
tree276ea8cde3117a583e2003696516a9e8b146047b /sys-devel/llvm
parentwww-apps/agendav: fix sed to use a file, bug #651236 (diff)
downloadgentoo-ea7b6929b52c6571eadd5d6fd6fb3f8e266a3e1e.tar.gz
gentoo-ea7b6929b52c6571eadd5d6fd6fb3f8e266a3e1e.tar.bz2
gentoo-ea7b6929b52c6571eadd5d6fd6fb3f8e266a3e1e.zip
sys-devel/llvm: Apply -fno-bmi only on x86 arches
Closes: https://bugs.gentoo.org/650506
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-6.0.0.ebuild5
-rw-r--r--sys-devel/llvm/llvm-6.0.9999.ebuild5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-6.0.0.ebuild b/sys-devel/llvm/llvm-6.0.0.ebuild
index 506dba50c90e..9e9f2c105090 100644
--- a/sys-devel/llvm/llvm-6.0.0.ebuild
+++ b/sys-devel/llvm/llvm-6.0.0.ebuild
@@ -172,7 +172,10 @@ multilib_src_configure() {
# workaround BMI bug in gcc-7 (fixed in 7.4)
# https://bugs.gentoo.org/649880
- if tc-is-gcc && [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]; then
+ # apply only to x86, https://bugs.gentoo.org/650506
+ if tc-is-gcc && [[ ${MULTILIB_ABI_FLAG} == abi_x86* ]] &&
+ [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]
+ then
local CFLAGS="${CFLAGS} -mno-bmi"
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi
diff --git a/sys-devel/llvm/llvm-6.0.9999.ebuild b/sys-devel/llvm/llvm-6.0.9999.ebuild
index 157cf1fbd33c..6276ab4925ae 100644
--- a/sys-devel/llvm/llvm-6.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-6.0.9999.ebuild
@@ -172,7 +172,10 @@ multilib_src_configure() {
# workaround BMI bug in gcc-7 (fixed in 7.4)
# https://bugs.gentoo.org/649880
- if tc-is-gcc && [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]; then
+ # apply only to x86, https://bugs.gentoo.org/650506
+ if tc-is-gcc && [[ ${MULTILIB_ABI_FLAG} == abi_x86* ]] &&
+ [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]
+ then
local CFLAGS="${CFLAGS} -mno-bmi"
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 7699f3364d0c..414c82e01aa5 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -174,7 +174,10 @@ multilib_src_configure() {
# workaround BMI bug in gcc-7 (fixed in 7.4)
# https://bugs.gentoo.org/649880
- if tc-is-gcc && [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]; then
+ # apply only to x86, https://bugs.gentoo.org/650506
+ if tc-is-gcc && [[ ${MULTILIB_ABI_FLAG} == abi_x86* ]] &&
+ [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]
+ then
local CFLAGS="${CFLAGS} -mno-bmi"
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi