summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-31 11:06:19 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-31 11:06:43 +0200
commitfdc5c9ad82c8360a04730109849235deb839db89 (patch)
treef7132e0de703339607f64250797e4f2b9f36c39e /sys-devel/make/make-4.2-r1.ebuild
parentsys-devel/make: Revbump to add upstream fix for bug #583812. (diff)
downloadgentoo-fdc5c9ad82c8360a04730109849235deb839db89.tar.gz
gentoo-fdc5c9ad82c8360a04730109849235deb839db89.tar.bz2
gentoo-fdc5c9ad82c8360a04730109849235deb839db89.zip
sys-devel/make: Removed old.
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/make/make-4.2-r1.ebuild')
-rw-r--r--sys-devel/make/make-4.2-r1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-devel/make/make-4.2-r1.ebuild b/sys-devel/make/make-4.2-r1.ebuild
deleted file mode 100644
index 4f5d2e3f6783..000000000000
--- a/sys-devel/make/make-4.2-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Standard tool to compile source trees"
-HOMEPAGE="https://www.gnu.org/software/make/make.html"
-SRC_URI="mirror://gnu//make/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="guile nls static"
-
-CDEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libintl )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
-
- # Revert this upstream commit until a real fix is available.
- # See https://bugs.gentoo.org/583812
- EPATCH_OPTS="-R" \
- epatch "${FILESDIR}"/${PN}-4.1-fix_double_colon_rules_plus_parallel_builds.patch
-}
-
-src_configure() {
- use static && append-ldflags -static
- econf \
- --program-prefix=g \
- $(use_with guile) \
- $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS README*
- if [[ ${USERLAND} == "GNU" ]] ; then
- # we install everywhere as 'gmake' but on GNU systems,
- # symlink 'make' to 'gmake'
- dosym gmake /usr/bin/make
- dosym gmake.1 /usr/share/man/man1/make.1
- fi
-}