summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-14 18:24:20 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-14 18:27:58 +0200
commit4fc1e8ada0799f72570e3c362af703dc17f81650 (patch)
tree48d9647ddbbc5538e430654755571256dabcf343 /sys-devel/make/make-4.2.1.ebuild
parentmedia-libs/giflib: Replace eutils inherit w/ split eclasses (diff)
downloadgentoo-4fc1e8ada0799f72570e3c362af703dc17f81650.tar.gz
gentoo-4fc1e8ada0799f72570e3c362af703dc17f81650.tar.bz2
gentoo-4fc1e8ada0799f72570e3c362af703dc17f81650.zip
Revert "sys-devel/make: default CXX to c++ instead of g++, #589894"
The change was accidentally done to the stable ebuild. Will reland with ~arch revbump. Reverts: bace4a893fbf789675d576be2a291aef33db90f5
Diffstat (limited to 'sys-devel/make/make-4.2.1.ebuild')
-rw-r--r--sys-devel/make/make-4.2.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-devel/make/make-4.2.1.ebuild b/sys-devel/make/make-4.2.1.ebuild
new file mode 100644
index 000000000000..70e90b6bf623
--- /dev/null
+++ b/sys-devel/make/make-4.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Standard tool to compile source trees"
+HOMEPAGE="https://www.gnu.org/software/make/make.html"
+SRC_URI="mirror://gnu//make/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="guile nls static"
+
+CDEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --program-prefix=g \
+ $(use_with guile) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README*
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # we install everywhere as 'gmake' but on GNU systems,
+ # symlink 'make' to 'gmake'
+ dosym gmake /usr/bin/make
+ dosym gmake.1 /usr/share/man/man1/make.1
+ fi
+}