summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Ilinykh <rion4ik@gmail.com>2017-12-22 12:39:36 +0500
committerMichał Górny <mgorny@gentoo.org>2018-03-03 14:19:36 +0100
commit2fd0f5df7b157b5f3a32144c391d89357c3a9044 (patch)
tree1058b0e576c1a50bb14bce8747aded8ba2df77a6 /sys-devel/qconf
parentapp-emacs/slime: stable 2.15 for ppc, bug #621516 (diff)
downloadgentoo-2fd0f5df7b157b5f3a32144c391d89357c3a9044.tar.gz
gentoo-2fd0f5df7b157b5f3a32144c391d89357c3a9044.tar.bz2
gentoo-2fd0f5df7b157b5f3a32144c391d89357c3a9044.zip
sys-devel/qconf: bumped to 2.4
Closes: https://bugs.gentoo.org/642084 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-devel/qconf')
-rw-r--r--sys-devel/qconf/Manifest1
-rw-r--r--sys-devel/qconf/metadata.xml9
-rw-r--r--sys-devel/qconf/qconf-2.4.ebuild39
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-devel/qconf/Manifest b/sys-devel/qconf/Manifest
index 9e33b357bf37..55a90ad5eb85 100644
--- a/sys-devel/qconf/Manifest
+++ b/sys-devel/qconf/Manifest
@@ -1 +1,2 @@
DIST qconf-2.3.tar.xz 51848 BLAKE2B 836f22e50cd4c9bb2beefd85d0e5f85f7aee40078dd4a696492c344ae9dffeae20840025a3262b5abcc2c74b22ed9e0bd4b44d077b83ab1e904c0a93bde394ff SHA512 27a532cb52067707a3e04a40260bb0f42e40adff4a643d2f048832356de58271e4051c9cb810e6fffd4b4e45dba483ed65aec062506053caa262ac03b3ec6253
+DIST qconf-2.4.tar.xz 51880 BLAKE2B c87a2a6dbca56fa52bccd0cdbbdba64013adcbf03c6cca6744d3e1c3166f74a09e945022854b1143e0c08a70a6124c0b890be8d7f9d4a91be7c6c0e2c89bf800 SHA512 982ace9e1d30f6c92078d661e103418fc7e3352a56eb78dae64a004e563f5e7bbf8f71972ca482e2f5229a6f88bb51372e543833f99c4b596d0ae4be5f443317
diff --git a/sys-devel/qconf/metadata.xml b/sys-devel/qconf/metadata.xml
index 93b766b33a89..38c51c97ddcd 100644
--- a/sys-devel/qconf/metadata.xml
+++ b/sys-devel/qconf/metadata.xml
@@ -1,6 +1,15 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>rion4ik@gmail.com</email>
+ <name>Sergey Ilinykh</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Configuration tool for Qt-based projects</longdescription>
<upstream>
<remote-id type="github">psi-plus/qconf</remote-id>
</upstream>
diff --git a/sys-devel/qconf/qconf-2.4.ebuild b/sys-devel/qconf/qconf-2.4.ebuild
new file mode 100644
index 000000000000..8dd2ae4e5182
--- /dev/null
+++ b/sys-devel/qconf/qconf-2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="https://github.com/psi-plus/qconf"
+SRC_URI="http://psi-im.org/files/qconf/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # not autotools configure. generates warnings for some autotools params.
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --qtdir="$(qt5_get_libdir)/qt5" \
+ --extraconf=QMAKE_STRIP= \
+ --verbose || die "configure failed"
+
+ # just to set all the Gentoo toolchain flags
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ dodoc -r examples
+}