summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2018-02-14 13:32:43 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2018-02-14 13:37:03 +0100
commitae3c38350efab149e32d974d8642891f69f375a3 (patch)
treee4ee64fa35d130d826b6808fca8de7ec4733adbe /sys-devel/sparse/sparse-9999.ebuild
parentnet-p2p/pybitmessage: remove vulnerable 0.6.2-r2 (diff)
downloadgentoo-ae3c38350efab149e32d974d8642891f69f375a3.tar.gz
gentoo-ae3c38350efab149e32d974d8642891f69f375a3.tar.bz2
gentoo-ae3c38350efab149e32d974d8642891f69f375a3.zip
sys-devel/sparse: modernize
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-devel/sparse/sparse-9999.ebuild')
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index 8771de72828a..aad07d85db73 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,26 +1,23 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
inherit eutils multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
- inherit git-2
-fi
DESCRIPTION="C semantic parser"
HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
- #KEYWORDS=""
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
+ KEYWORDS=""
else
- SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.xz"
+ SRC_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git/snapshot/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
-LICENSE="OSL-1.1"
+LICENSE="MIT"
SLOT="0"
IUSE="gtk llvm test xml"
@@ -31,15 +28,18 @@ DEPEND="${RDEPEND}
gtk? ( virtual/pkgconfig )
xml? ( virtual/pkgconfig )"
+PATCHES=( "${FILESDIR}/${PN}-0.5.1-cmdline-include.patch" )
+
src_prepare() {
tc-export AR CC PKG_CONFIG
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
- -e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
+ -e '/^COMMON_CFLAGS =/{s:=:= $(CPPFLAGS):;s:-O2 -finline-functions -fno-strict-aliasing -g:-fno-strict-aliasing:}' \
-e "s:pkg-config:${PKG_CONFIG}:" \
Makefile || die
export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LLVM=$(usex llvm) HAVE_LIBXML=$(usex xml)"
+ default
}
src_compile() {