summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-02-26 18:46:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-02-26 18:46:14 +0000
commite7f7c4605c082e91ddf8d62b497e5266cb2a8668 (patch)
tree5bfdf5f081813a117912012901caf4428eaa3383 /sys-devel/sparse/sparse-9999.ebuild
parentmedia-gfx/rawtherapee: version bump to 5.8 (diff)
downloadgentoo-e7f7c4605c082e91ddf8d62b497e5266cb2a8668.tar.gz
gentoo-e7f7c4605c082e91ddf8d62b497e5266cb2a8668.tar.bz2
gentoo-e7f7c4605c082e91ddf8d62b497e5266cb2a8668.zip
sys-devel/sparse: pin to specific LLVM slot
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/sparse/sparse-9999.ebuild')
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index fa4c7a97fab9..8df52ef8a1e5 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils multilib toolchain-funcs
+inherit eutils llvm multilib toolchain-funcs
DESCRIPTION="C semantic parser"
HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
@@ -22,8 +22,10 @@ SLOT="0"
IUSE="gtk llvm test xml"
RESTRICT="!test? ( test )"
+LLVM_MAX_SLOT=9
+
RDEPEND="gtk? ( x11-libs/gtk+:2 )
- llvm? ( >=sys-devel/llvm-3.0 )
+ llvm? ( sys-devel/llvm:${LLVM_MAX_SLOT}= )
xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}
gtk? ( virtual/pkgconfig )