summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2018-03-09 02:56:21 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2018-03-09 02:56:49 +0100
commitf97a3b2c17462a50d3b65c53bc0d4fea164c4185 (patch)
treef5bfcb1fbb194976e0a428580cc746662b31fa4d /sys-devel/sparse
parentdev-db/mariadb: Restore ~arm keyword on 10.2.13 (diff)
downloadgentoo-f97a3b2c17462a50d3b65c53bc0d4fea164c4185.tar.gz
gentoo-f97a3b2c17462a50d3b65c53bc0d4fea164c4185.tar.bz2
gentoo-f97a3b2c17462a50d3b65c53bc0d4fea164c4185.zip
sys-devel/sparse: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/Manifest1
-rw-r--r--sys-devel/sparse/sparse-0.5.2_rc1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-devel/sparse/Manifest b/sys-devel/sparse/Manifest
index d6cc9aa66063..438d91cbbf88 100644
--- a/sys-devel/sparse/Manifest
+++ b/sys-devel/sparse/Manifest
@@ -1 +1,2 @@
DIST sparse-0.5.1.tar.xz 215144 BLAKE2B 209aa7cf34a9135dae38466a0ba41ff4fb888c363ed59a68a5820d4b6ef1636d717b8172a6d638d9dbc61197efb7a3e06ef85830b6f1c359737520b4b3aa0fbe SHA512 f7fc516ef8343a4153b9bda1b50b326dcd55a77fce5acccd9aa4c5636d6510573c7e26b0a7ca1df847082faf2be2d292336ad1cec855e395703a6b1e04d3a8a1
+DIST sparse-0.5.2-rc1.tar.gz 282810 BLAKE2B 74d06230ceb06dac427984c365223633ef795b2f6329c69da5183b9f3444457ee05d74b04b18cf400b4d813026a746218edbf9bc0b2aa371c8a3681ac10ce19b SHA512 b58458b97e91b7d02d032a946d9870a3fd227959608fb7847864ad1a92258aeb0461da513f4d6d3b37791ed8d5fc41ac01cfef0fcaf34b229090ff078672ef40
diff --git a/sys-devel/sparse/sparse-0.5.2_rc1.ebuild b/sys-devel/sparse/sparse-0.5.2_rc1.ebuild
new file mode 100644
index 000000000000..69c8ce4c6c75
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.5.2_rc1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="https://sparse.wiki.kernel.org/index.php/Main_Page"
+
+RC_COMMIT=d1c2f8d3d4205ca1ae7cf0ec2cbd89a7fce73e5c
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://git.kernel.org/pub/scm/devel/${PN}/${PN}.git/snapshot/${PN}-${RC_COMMIT}.tar.gz -> ${PN}-${PV/_/-}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gtk llvm test xml"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ llvm? ( >=sys-devel/llvm-3.0 )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+S="${WORKDIR}/sparse-${RC_COMMIT}"
+
+src_prepare() {
+ tc-export AR CC PKG_CONFIG
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^COMMON_CFLAGS =/{s:=:= $(CPPFLAGS):;s:-O2 -finline-functions -fno-strict-aliasing -g:-fno-strict-aliasing:}' \
+ -e "s:pkg-config:${PKG_CONFIG}:" \
+ Makefile || die
+ export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LLVM=$(usex llvm) HAVE_LIBXML=$(usex xml)"
+ default
+}
+
+src_compile() {
+ emake $(usex test all all-installable)
+}