summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-06-23 20:18:04 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-24 15:06:20 +0200
commit119a2ddba9b5bdfb0554839b965f3cb150d890ab (patch)
tree356f79710f5d24bc2a76b036a0eb82140277e069 /sys-devel
parentsys-devel/parity: update HOMEPAGE (diff)
downloadgentoo-119a2ddba9b5bdfb0554839b965f3cb150d890ab.tar.gz
gentoo-119a2ddba9b5bdfb0554839b965f3cb150d890ab.tar.bz2
gentoo-119a2ddba9b5bdfb0554839b965f3cb150d890ab.zip
sys-devel/parity: remove live ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/parity/parity-9999.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/sys-devel/parity/parity-9999.ebuild b/sys-devel/parity/parity-9999.ebuild
deleted file mode 100644
index 3de370518ab4..000000000000
--- a/sys-devel/parity/parity-9999.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == 9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="git@github.com:ssi-schaefer/parity.git https://github.com/ssi-schaefer/parity.git"
- BDEPEND="dev-util/confix"
-else
- SRC_URI="https://github.com/ssi-schaefer/${PN}/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="~x64-cygwin"
-fi
-DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
-HOMEPAGE="https://github.com/ssi-schaefer/parity"
-
-parity-vcarchs() { echo x64=x86_64 x86=i686 ; }
-parity-vcvers-legacy() { echo 8_0 9_0 ; }
-parity-vcvers-current() { echo 10_0 11_0 12_0 14_0 15 16 ; }
-parity-vcvers() {
- parity-vcvers-legacy
- parity-vcvers-current
-}
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="$(
- for a in $(parity-vcarchs); do echo "+vc${a%=*}"; done
- for v in $(parity-vcvers-legacy); do echo "vc${v}"; done
- for v in $(parity-vcvers-current); do echo "+vc${v}"; done
-)"
-
-if [[ ${PV} == 9999 ]]; then
- src_prepare() {
- default
- confix --output || die
- eautoreconf
- }
-fi
-
-parity-enabled-vcarchs() {
- local enabled= a
- for a in $(parity-vcarchs) ; do
- if use vc${a%=*} ; then
- enabled+=",${a#*=}"
- fi
- done
- echo ${enabled#,}
-}
-
-parity-enabled-vcvers() {
- local enabled= v
- for v in $(parity-vcvers) ; do
- if use vc${v} ; then
- enabled+=",${v/_/.}"
- fi
- done
- echo ${enabled#,}
-}
-
-src_configure() {
- local myconf=(
- --enable-msvc-archs="$(parity-enabled-vcarchs)"
- --enable-msvc-versions="$(parity-enabled-vcvers)"
- --disable-default-msvc-version
- )
- econf "${myconf[@]}"
-}
-
-pkg_postinst() {
- if [[ -n ${ROOT} ]] ; then
- einfo "To enable all available MSVC versions, on the target machine please run:"
- einfo " '${EPREFIX}/usr/bin/parity-setup' --enable-all"
- else
- "${EPREFIX}"/usr/bin/parity-setup --enable-all
- fi
-}