summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLei Zhang <zhanglei.april@gmail.com>2016-07-28 05:36:35 +0800
committerMichał Górny <mgorny@gentoo.org>2017-04-14 18:27:59 +0200
commit41815b5598cad067c07e1c6f09b118e2114a675f (patch)
tree48e07e29cef0eb4298d8b1c1b27459e3cf93818d /sys-devel
parentRevert "sys-devel/make: default CXX to c++ instead of g++, #589894" (diff)
downloadgentoo-41815b5598cad067c07e1c6f09b118e2114a675f.tar.gz
gentoo-41815b5598cad067c07e1c6f09b118e2114a675f.tar.bz2
gentoo-41815b5598cad067c07e1c6f09b118e2114a675f.zip
sys-devel/make: default CXX to c++ instead of g++, #589894
Now with ~arch revbump! Closes: https://github.com/gentoo/gentoo/pull/1982 Package-Manager: portage-2.2.28 Reviewed-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/make/files/make-4.2-default-cxx.patch13
-rw-r--r--sys-devel/make/make-4.2.1-r1.ebuild49
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-devel/make/files/make-4.2-default-cxx.patch b/sys-devel/make/files/make-4.2-default-cxx.patch
new file mode 100644
index 000000000000..4d592086a6ff
--- /dev/null
+++ b/sys-devel/make/files/make-4.2-default-cxx.patch
@@ -0,0 +1,13 @@
+diff --git a/default.c b/default.c
+index 3d865c7..e8b3ed6 100644
+--- a/default.c
++++ b/default.c
+@@ -530,7 +530,7 @@ static const char *default_variables[] =
+ "OBJC", "gcc",
+ #else
+ "CC", "cc",
+- "CXX", "g++",
++ "CXX", "c++",
+ "OBJC", "cc",
+ #endif
+
diff --git a/sys-devel/make/make-4.2.1-r1.ebuild b/sys-devel/make/make-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..2b944c675fad
--- /dev/null
+++ b/sys-devel/make/make-4.2.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Standard tool to compile source trees"
+HOMEPAGE="https://www.gnu.org/software/make/make.html"
+SRC_URI="mirror://gnu//make/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="guile nls static"
+
+CDEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
+ "${FILESDIR}"/${PN}-4.2-default-cxx.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --program-prefix=g \
+ $(use_with guile) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README*
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # we install everywhere as 'gmake' but on GNU systems,
+ # symlink 'make' to 'gmake'
+ dosym gmake /usr/bin/make
+ dosym gmake.1 /usr/share/man/man1/make.1
+ fi
+}