summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-29 10:08:29 +0200
committerMichał Górny <mgorny@gentoo.org>2018-03-29 12:19:19 +0200
commit7723c753445eac3af8ad7ef85e567a3ced904f83 (patch)
treeb2c79711b9d61b736357c07233d2eff97f792c54 /sys-devel
parentsys-devel/clang: Remove non-Darwin keywords from 3.7.1 (diff)
downloadgentoo-7723c753445eac3af8ad7ef85e567a3ced904f83.tar.gz
gentoo-7723c753445eac3af8ad7ef85e567a3ced904f83.tar.bz2
gentoo-7723c753445eac3af8ad7ef85e567a3ced904f83.zip
sys-devel/llvm: Remove non-arm & non-Darwin keywords from 3.7.1
Closes: https://github.com/gentoo/gentoo/pull/7690
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-3.7.1-r3.ebuild18
1 files changed, 3 insertions, 15 deletions
diff --git a/sys-devel/llvm/llvm-3.7.1-r3.ebuild b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
index 89214c8b5379..c176d25b8fdb 100644
--- a/sys-devel/llvm/llvm-3.7.1-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,13 +30,12 @@ SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz
LICENSE="UoI-NCSA rc BSD public-domain
arm? ( LLVM-Grant )
- arm64? ( LLVM-Grant )
multitarget? ( LLVM-Grant )"
SLOT="0/${PV}"
-KEYWORDS="amd64 arm ~arm64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="arm ~ppc-macos ~x64-macos ~x86-macos"
IUSE="clang debug doc gold libedit +libffi lldb multitarget ncurses ocaml
python +static-analyzer test xml video_cards_radeon
- kernel_Darwin kernel_FreeBSD"
+ kernel_Darwin"
COMMON_DEPEND="
sys-libs/zlib:0=
@@ -453,11 +452,6 @@ src_install() {
fi
multilib-minimal_src_install
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD && use clang; then
- rm "${ED}"usr/lib/clang/${PV}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {
@@ -565,9 +559,3 @@ multilib_src_install_all() {
fi
fi
}
-
-pkg_postinst() {
- if use clang && ! has_version sys-libs/libomp; then
- elog "To enable OpenMP support in clang, install sys-libs/libomp."
- fi
-}