summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-18 22:49:22 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-19 10:13:58 +0100
commit8797c1711155c9c6cb3f2f1b8486eba0a9a23d82 (patch)
tree0a8cd1e555f145669ff84f259d3aacedbda8adf1 /sys-devel
parentapp-misc/screen: update fix for Solaris (diff)
downloadgentoo-8797c1711155c9c6cb3f2f1b8486eba0a9a23d82.tar.gz
gentoo-8797c1711155c9c6cb3f2f1b8486eba0a9a23d82.tar.bz2
gentoo-8797c1711155c9c6cb3f2f1b8486eba0a9a23d82.zip
sys-devel/clang: Build tests in src_compile()
Build tests in src_compile() (when enabled) rather than delaying that until src_test(). This ensures a better split between compilation phase and testing in multilib builds, i.e. you can turn off other distcc servers when first ABI starts testing. Also, it guarantees that building the tests will be tested for all ABIs, even if the actual tests fail for one of them.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-9999.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 3dfce9b7a44a..035ac3d35270 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -141,8 +141,7 @@ multilib_src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
- # TODO: get them properly conditional
- #-DLLVM_BUILD_TESTS=$(usex test)
+ -DLLVM_BUILD_TESTS=$(usex test)
# these are not propagated reliably, so redefine them
-DLLVM_ENABLE_EH=ON