summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Ratiu <adrian.ratiu@collabora.com>2022-01-14 19:42:24 +0200
committerSam James <sam@gentoo.org>2022-01-14 18:47:03 +0000
commitbdc76112c33f0cc7606a88be8e3d4c7498b29cc7 (patch)
tree393e0707c007dd76041fcec9171fc1f3dcc13472 /sys-devel
parentnet-irc/quassel: fix CXXFLAGS de-duplication (diff)
downloadgentoo-bdc76112c33f0cc7606a88be8e3d4c7498b29cc7.tar.gz
gentoo-bdc76112c33f0cc7606a88be8e3d4c7498b29cc7.tar.bz2
gentoo-bdc76112c33f0cc7606a88be8e3d4c7498b29cc7.zip
sys-devel/gdb: fix GCC/Clang build mixture
GDB configure will use a mix of GCC and Clang due to $GCC_FOR_TARGET defaulting to GCC in Clang-configured builds, so set the var to ensure the proper compilers are detected and to avoid mixing them. Before setting the variable (example from ChromiumOS): checking for x86_64-cros-linux-gnu-gcc... x86_64-cros-linux-gnu-gcc After: checking for gcc... (cached) x86_64-cros-linux-gnu-clang Bug: https://bugs.gentoo.org/831202 Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com> Closes: https://github.com/gentoo/gentoo/pull/23796 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/gdb-10.2-r1.ebuild3
-rw-r--r--sys-devel/gdb/gdb-11.1.ebuild3
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/sys-devel/gdb/gdb-10.2-r1.ebuild b/sys-devel/gdb/gdb-10.2-r1.ebuild
index 1978ab28268d..19f08197ce03 100644
--- a/sys-devel/gdb/gdb-10.2-r1.ebuild
+++ b/sys-devel/gdb/gdb-10.2-r1.ebuild
@@ -188,6 +188,9 @@ src_configure() {
# source-highlight is detected with pkg-config: bug #716558
export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+ # ensure proper compiler is detected for Clang builds: bug #831202
+ export GCC_FOR_TARGET="${CC_FOR_TARGET:-$(tc-getCC)}"
+
econf "${myconf[@]}"
}
diff --git a/sys-devel/gdb/gdb-11.1.ebuild b/sys-devel/gdb/gdb-11.1.ebuild
index 022f3be33ce7..3933cc2776b8 100644
--- a/sys-devel/gdb/gdb-11.1.ebuild
+++ b/sys-devel/gdb/gdb-11.1.ebuild
@@ -193,6 +193,9 @@ src_configure() {
# source-highlight is detected with pkg-config: bug #716558
export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+ # ensure proper compiler is detected for Clang builds: bug #831202
+ export GCC_FOR_TARGET="${CC_FOR_TARGET:-$(tc-getCC)}"
+
econf "${myconf[@]}"
}
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 462b5c95a692..1725c16abdac 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -192,6 +192,9 @@ src_configure() {
# source-highlight is detected with pkg-config: bug #716558
export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+ # ensure proper compiler is detected for Clang builds: bug #831202
+ export GCC_FOR_TARGET="${CC_FOR_TARGET:-$(tc-getCC)}"
+
econf "${myconf[@]}"
}