summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-28 12:54:12 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-28 14:35:59 +0100
commitc1903d8f3d67d89a15e898b71f37b0050dc54b0f (patch)
tree8ccce6de7c438be37dc03e54d6686f75da3616c8 /sys-devel
parentsys-devel/distcc: Fix for prefix (diff)
downloadgentoo-c1903d8f3d67d89a15e898b71f37b0050dc54b0f.tar.gz
gentoo-c1903d8f3d67d89a15e898b71f37b0050dc54b0f.tar.bz2
gentoo-c1903d8f3d67d89a15e898b71f37b0050dc54b0f.zip
sys-devel/clang: Prefix love
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-2.8-r3.ebuild4
-rw-r--r--sys-devel/clang/clang-2.9-r1.ebuild4
-rw-r--r--sys-devel/clang/clang-3.0-r4.ebuild4
-rw-r--r--sys-devel/clang/clang-3.1-r5.ebuild4
-rw-r--r--sys-devel/clang/metadata.xml6
5 files changed, 11 insertions, 11 deletions
diff --git a/sys-devel/clang/clang-2.8-r3.ebuild b/sys-devel/clang/clang-2.8-r3.ebuild
index 3a4b53a1fcc0..ac9afdee1640 100644
--- a/sys-devel/clang/clang-2.8-r3.ebuild
+++ b/sys-devel/clang/clang-2.8-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -156,7 +156,7 @@ src_install() {
install-scan-view() {
insinto "$(python_get_sitedir)"/clang
doins Reporter.py Resources ScanView.py startfile.py
- touch "${ED}"/"$(python_get_sitedir)"/clang/__init__.py
+ touch "${D}"/"$(python_get_sitedir)"/clang/__init__.py
}
python_execute_function install-scan-view
fi
diff --git a/sys-devel/clang/clang-2.9-r1.ebuild b/sys-devel/clang/clang-2.9-r1.ebuild
index b53bf23b279f..e0b24139a9cf 100644
--- a/sys-devel/clang/clang-2.9-r1.ebuild
+++ b/sys-devel/clang/clang-2.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -145,7 +145,7 @@ src_install() {
install-scan-view() {
insinto "$(python_get_sitedir)"/clang
doins Reporter.py Resources ScanView.py startfile.py
- touch "${ED}"/"$(python_get_sitedir)"/clang/__init__.py
+ touch "${D}"/"$(python_get_sitedir)"/clang/__init__.py
}
python_execute_function install-scan-view
fi
diff --git a/sys-devel/clang/clang-3.0-r4.ebuild b/sys-devel/clang/clang-3.0-r4.ebuild
index 3834aa49c83c..dfd288b9bd8e 100644
--- a/sys-devel/clang/clang-3.0-r4.ebuild
+++ b/sys-devel/clang/clang-3.0-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -163,7 +163,7 @@ src_install() {
install-scan-view() {
insinto "$(python_get_sitedir)"/clang
doins Reporter.py Resources ScanView.py startfile.py
- touch "${ED}"/"$(python_get_sitedir)"/clang/__init__.py
+ touch "${D}"/"$(python_get_sitedir)"/clang/__init__.py
}
python_execute_function install-scan-view
fi
diff --git a/sys-devel/clang/clang-3.1-r5.ebuild b/sys-devel/clang/clang-3.1-r5.ebuild
index f98c99723b5f..34f3243e11bd 100644
--- a/sys-devel/clang/clang-3.1-r5.ebuild
+++ b/sys-devel/clang/clang-3.1-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -163,7 +163,7 @@ src_install() {
install-scan-view() {
insinto "$(python_get_sitedir)"/clang
doins Reporter.py Resources ScanView.py startfile.py
- touch "${ED}"/"$(python_get_sitedir)"/clang/__init__.py
+ touch "${D}"/"$(python_get_sitedir)"/clang/__init__.py
}
python_execute_function install-scan-view
fi
diff --git a/sys-devel/clang/metadata.xml b/sys-devel/clang/metadata.xml
index 466ad974778a..8c2afb8a2ace 100644
--- a/sys-devel/clang/metadata.xml
+++ b/sys-devel/clang/metadata.xml
@@ -28,8 +28,8 @@ A simple and hackable code base
A single unified parser for C, Objective C, C++, and Objective C++
Conformance with C/C++/ObjC and their variants</longdescription>
<use>
- <flag name='multitarget'>Build all host targets (default: host only)</flag>
- <flag name='static-analyzer'>Install the Clang static analyzer</flag>
- <flag name='system-cxx-headers'>By default, clang++ searchs for C++ headers in a series of hardcoded paths. Enabling this flag will force it to use the active gcc profile ones</flag>
+ <flag name="multitarget">Build all host targets (default: host only)</flag>
+ <flag name="static-analyzer">Install the Clang static analyzer</flag>
+ <flag name="system-cxx-headers">By default, clang++ searchs for C++ headers in a series of hardcoded paths. Enabling this flag will force it to use the active gcc profile ones</flag>
</use>
</pkgmetadata>