summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-05 10:36:11 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-05 11:55:46 +0100
commitcd3f25deb13cf4d6c9d721d515dbf772a988426f (patch)
tree423ea2268525779097c812fd1bef71091c26dc89 /sys-devel
parentsys-apps/openrc: arm stable wrt bug #704600 (diff)
downloadgentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.tar.gz
gentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.tar.bz2
gentoo-cd3f25deb13cf4d6c9d721d515dbf772a988426f.zip
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-10.0.0.9999.ebuild4
-rw-r--r--sys-devel/clang/clang-9.0.0.ebuild4
-rw-r--r--sys-devel/clang/clang-9.0.1.ebuild4
-rw-r--r--sys-devel/distcc/distcc-3.3.3.ebuild4
-rw-r--r--sys-devel/gdb/gdb-8.3.1.ebuild4
-rw-r--r--sys-devel/gdb/gdb-8.3.ebuild4
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild4
-rw-r--r--sys-devel/lld/lld-10.0.0.9999.ebuild4
-rw-r--r--sys-devel/lld/lld-9.0.0.ebuild4
-rw-r--r--sys-devel/lld/lld-9.0.1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-10.0.0.9999.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9.0.0.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9.0.1.ebuild4
13 files changed, 26 insertions, 26 deletions
diff --git a/sys-devel/clang/clang-10.0.0.9999.ebuild b/sys-devel/clang/clang-10.0.0.9999.ebuild
index 8201088ceb49..78e777565781 100644
--- a/sys-devel/clang/clang-10.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-10.0.0.9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm llvm.org multilib-minimal multiprocessing \
pax-utils python-single-r1 toolchain-funcs
diff --git a/sys-devel/clang/clang-9.0.0.ebuild b/sys-devel/clang/clang-9.0.0.ebuild
index 0cda471eae92..b9a8fd171342 100644
--- a/sys-devel/clang/clang-9.0.0.ebuild
+++ b/sys-devel/clang/clang-9.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm llvm.org multilib-minimal multiprocessing \
pax-utils python-single-r1 toolchain-funcs
diff --git a/sys-devel/clang/clang-9.0.1.ebuild b/sys-devel/clang/clang-9.0.1.ebuild
index a35a53b3b76d..c72230eaae4f 100644
--- a/sys-devel/clang/clang-9.0.1.ebuild
+++ b/sys-devel/clang/clang-9.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm llvm.org multilib-minimal multiprocessing \
pax-utils python-single-r1 toolchain-funcs
diff --git a/sys-devel/distcc/distcc-3.3.3.ebuild b/sys-devel/distcc/distcc-3.3.3.ebuild
index f0094b71e4ae..bb6a39b7e51b 100644
--- a/sys-devel/distcc/distcc-3.3.3.ebuild
+++ b/sys-devel/distcc/distcc-3.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_6 )
inherit autotools flag-o-matic python-single-r1 systemd \
toolchain-funcs user xdg-utils prefix
diff --git a/sys-devel/gdb/gdb-8.3.1.ebuild b/sys-devel/gdb/gdb-8.3.1.ebuild
index f7413e82432b..a818c73f4771 100644
--- a/sys-devel/gdb/gdb-8.3.1.ebuild
+++ b/sys-devel/gdb/gdb-8.3.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
inherit eutils flag-o-matic python-single-r1
diff --git a/sys-devel/gdb/gdb-8.3.ebuild b/sys-devel/gdb/gdb-8.3.ebuild
index 1d67160a80fa..7a0a6a6c29c5 100644
--- a/sys-devel/gdb/gdb-8.3.ebuild
+++ b/sys-devel/gdb/gdb-8.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
inherit eutils flag-o-matic python-single-r1
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 635cd50b6fb2..9fc57491538d 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
inherit eutils flag-o-matic python-single-r1
diff --git a/sys-devel/lld/lld-10.0.0.9999.ebuild b/sys-devel/lld/lld-10.0.0.9999.ebuild
index fed376f6958a..8d0d48bb02cc 100644
--- a/sys-devel/lld/lld-10.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-10.0.0.9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
diff --git a/sys-devel/lld/lld-9.0.0.ebuild b/sys-devel/lld/lld-9.0.0.ebuild
index ce499310894b..bb3df2a9ac7e 100644
--- a/sys-devel/lld/lld-9.0.0.ebuild
+++ b/sys-devel/lld/lld-9.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
diff --git a/sys-devel/lld/lld-9.0.1.ebuild b/sys-devel/lld/lld-9.0.1.ebuild
index ce499310894b..bb3df2a9ac7e 100644
--- a/sys-devel/lld/lld-9.0.1.ebuild
+++ b/sys-devel/lld/lld-9.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
diff --git a/sys-devel/llvm/llvm-10.0.0.9999.ebuild b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
index dc2114f9b45e..db347b40d25b 100644
--- a/sys-devel/llvm/llvm-10.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-10.0.0.9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm.org multilib-minimal multiprocessing \
pax-utils python-any-r1 toolchain-funcs
diff --git a/sys-devel/llvm/llvm-9.0.0.ebuild b/sys-devel/llvm/llvm-9.0.0.ebuild
index cffe2425c4f7..0edacf1f63d6 100644
--- a/sys-devel/llvm/llvm-9.0.0.ebuild
+++ b/sys-devel/llvm/llvm-9.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm.org multilib-minimal multiprocessing \
pax-utils python-any-r1 toolchain-funcs
diff --git a/sys-devel/llvm/llvm-9.0.1.ebuild b/sys-devel/llvm/llvm-9.0.1.ebuild
index ec830eb72e3b..d8c55d8f41b9 100644
--- a/sys-devel/llvm/llvm-9.0.1.ebuild
+++ b/sys-devel/llvm/llvm-9.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
inherit cmake-utils llvm.org multilib-minimal multiprocessing \
pax-utils python-any-r1 toolchain-funcs