summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-22 09:19:05 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-22 10:22:36 +0200
commitd91e28589fa227e35e143db5d622b9120f796db3 (patch)
treed281d1281383715796c5c11855ea9259a10ffa2a /sys-devel
parentsys-devel/clang: Drop old (5.0.1 & 6.0.0) (diff)
downloadgentoo-d91e28589fa227e35e143db5d622b9120f796db3.tar.gz
gentoo-d91e28589fa227e35e143db5d622b9120f796db3.tar.bz2
gentoo-d91e28589fa227e35e143db5d622b9120f796db3.zip
sys-devel/clang: Reshuffle patches
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-4.0.1.ebuild2
-rw-r--r--sys-devel/clang/clang-5.0.2.ebuild8
-rw-r--r--sys-devel/clang/clang-6.0.1.ebuild2
-rw-r--r--sys-devel/clang/files/5.0.2/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch (renamed from sys-devel/clang/files/5.0.1/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch)0
-rw-r--r--sys-devel/clang/files/5.0.2/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch (renamed from sys-devel/clang/files/5.0.1/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch)0
-rw-r--r--sys-devel/clang/files/5.0.2/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch (renamed from sys-devel/clang/files/5.0.1/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch)0
-rw-r--r--sys-devel/clang/files/6.0.1/darwin_prefix-include-paths.patch (renamed from sys-devel/clang/files/5.0.1/darwin_prefix-include-paths.patch)0
7 files changed, 6 insertions, 6 deletions
diff --git a/sys-devel/clang/clang-4.0.1.ebuild b/sys-devel/clang/clang-4.0.1.ebuild
index 672f7fc6097b..469a613db91a 100644
--- a/sys-devel/clang/clang-4.0.1.ebuild
+++ b/sys-devel/clang/clang-4.0.1.ebuild
@@ -89,7 +89,7 @@ src_unpack() {
src_prepare() {
# fix finding compiler-rt libs
- eapply "${FILESDIR}"/5.0.1/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
+ eapply "${FILESDIR}"/5.0.2/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
# fix stand-alone doc build
eapply "${FILESDIR}"/4.0.1/0007-cmake-Support-stand-alone-Sphinx-doxygen-doc-build.patch
diff --git a/sys-devel/clang/clang-5.0.2.ebuild b/sys-devel/clang/clang-5.0.2.ebuild
index 85f7d6b4404e..6e07de89a3b3 100644
--- a/sys-devel/clang/clang-5.0.2.ebuild
+++ b/sys-devel/clang/clang-5.0.2.ebuild
@@ -107,15 +107,15 @@ src_unpack() {
src_prepare() {
# fix finding compiler-rt libs
- eapply "${FILESDIR}"/5.0.1/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
+ eapply "${FILESDIR}"/5.0.2/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
# fix setting LD_LIBRARY_PATH for tests on *BSD
- eapply "${FILESDIR}"/5.0.1/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch
+ eapply "${FILESDIR}"/5.0.2/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch
# add Prefix include paths for Darwin
- eapply "${FILESDIR}"/5.0.1/darwin_prefix-include-paths.patch
+ eapply "${FILESDIR}"/6.0.1/darwin_prefix-include-paths.patch
cd tools/extra || die
# fix setting LD_LIBRARY_PATH for tests on *BSD (extra part)
- eapply "${FILESDIR}"/5.0.1/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch
+ eapply "${FILESDIR}"/5.0.2/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch
cd ../.. || die
cmake-utils_src_prepare
diff --git a/sys-devel/clang/clang-6.0.1.ebuild b/sys-devel/clang/clang-6.0.1.ebuild
index d42ae48d2ea2..6cd2169e898a 100644
--- a/sys-devel/clang/clang-6.0.1.ebuild
+++ b/sys-devel/clang/clang-6.0.1.ebuild
@@ -70,7 +70,7 @@ CMAKE_BUILD_TYPE=RelWithDebInfo
PATCHES=(
# add Prefix include paths for Darwin
- "${FILESDIR}"/5.0.1/darwin_prefix-include-paths.patch
+ "${FILESDIR}"/6.0.1/darwin_prefix-include-paths.patch
# fix test failure with default-compiler-rt
# https://bugs.gentoo.org/650316
diff --git a/sys-devel/clang/files/5.0.1/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch b/sys-devel/clang/files/5.0.2/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
index 7d53cbdef3f3..7d53cbdef3f3 100644
--- a/sys-devel/clang/files/5.0.1/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
+++ b/sys-devel/clang/files/5.0.2/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
diff --git a/sys-devel/clang/files/5.0.1/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch b/sys-devel/clang/files/5.0.2/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch
index 1751a4f479f0..1751a4f479f0 100644
--- a/sys-devel/clang/files/5.0.1/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch
+++ b/sys-devel/clang/files/5.0.2/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch
diff --git a/sys-devel/clang/files/5.0.1/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch b/sys-devel/clang/files/5.0.2/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch
index cbdb0b807aaf..cbdb0b807aaf 100644
--- a/sys-devel/clang/files/5.0.1/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch
+++ b/sys-devel/clang/files/5.0.2/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch
diff --git a/sys-devel/clang/files/5.0.1/darwin_prefix-include-paths.patch b/sys-devel/clang/files/6.0.1/darwin_prefix-include-paths.patch
index 7744b942d0e5..7744b942d0e5 100644
--- a/sys-devel/clang/files/5.0.1/darwin_prefix-include-paths.patch
+++ b/sys-devel/clang/files/6.0.1/darwin_prefix-include-paths.patch