summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-20 11:33:40 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-21 00:12:04 +0200
commitf79c01a793116bf00f1eff4b5cc2367aefe2d7d6 (patch)
treee5c7653975837cd5e8e5759b4315892ac0a22b6f /sys-devel
parentsys-libs/libomp: Bump to 9.0.0 (diff)
downloadgentoo-f79c01a793116bf00f1eff4b5cc2367aefe2d7d6.tar.gz
gentoo-f79c01a793116bf00f1eff4b5cc2367aefe2d7d6.tar.bz2
gentoo-f79c01a793116bf00f1eff4b5cc2367aefe2d7d6.zip
sys-devel/clang-runtime: Bump to 9.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-9.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-9.0.0.ebuild
new file mode 100644
index 000000000000..6204c849277c
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-9.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"