summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-05-07 23:28:02 +0200
committerHanno <hanno@gentoo.org>2018-06-21 20:59:20 +0200
commit06df722649b38d027a32cf58f47f144426e16c48 (patch)
tree4ea539bd720f1d084252b820ba3cba159c9e8c7e /sys-fs/ext3grep/ext3grep-0.10.2.ebuild
parentx11-terms/kitty: remove old (diff)
downloadgentoo-06df722649b38d027a32cf58f47f144426e16c48.tar.gz
gentoo-06df722649b38d027a32cf58f47f144426e16c48.tar.bz2
gentoo-06df722649b38d027a32cf58f47f144426e16c48.zip
sys-fs/ext3grep: Fix build with newer e2fsprogs version
Also bumped to EAPI=6 Closes: https://bugs.gentoo.org/650042 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'sys-fs/ext3grep/ext3grep-0.10.2.ebuild')
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.2.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
index 88c27978d04d..1c8c5533ad98 100644
--- a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
+++ b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils
+EAPI=6
DESCRIPTION="Recover deleted files on an ext3 file system"
HOMEPAGE="https://code.google.com/p/ext3grep/"
@@ -13,25 +12,24 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug pch"
-DOCS="NEWS README"
-
-RDEPEND=""
DEPEND="sys-fs/e2fsprogs
virtual/os-headers
virtual/pkgconfig"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-0.10.1-gcc44.patch \
- "${FILESDIR}"/${P}-include-unistd_h-for-sysconf.patch
+DOCS="NEWS README"
- # Fix build against latest e2fsprogs, taken from
- # https://code.google.com/p/ext3grep/issues/detail?id=34
- epatch "${FILESDIR}"/${P}-new-e2fsprogs.diff
-}
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10.1-gcc44.patch"
+ "${FILESDIR}/${P}-include-unistd_h-for-sysconf.patch"
+ "${FILESDIR}/${P}-new-e2fsprogs.patch"
+ "${FILESDIR}/${P}-newer-e2fsprogs.patch"
+)
src_configure() {
- econf \
- $(use_enable debug) \
+ myeconfargs=(
+ $(use_enable debug)
$(use_enable pch)
+ )
+
+ econf "${myeconfargs[@]}"
}