summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/inotify-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/Manifest2
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild34
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.14.ebuild34
-rw-r--r--sys-fs/inotify-tools/metadata.xml16
4 files changed, 86 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/Manifest b/sys-fs/inotify-tools/Manifest
new file mode 100644
index 000000000000..19a5856ab79f
--- /dev/null
+++ b/sys-fs/inotify-tools/Manifest
@@ -0,0 +1,2 @@
+DIST inotify-tools-3.13.tar.gz 389473 SHA256 464146acec2c118be63a6c2a090d9252fbe9689c093db85b695d0502fa229445 SHA512 e757ca5d3bac2b6b84e9435671107d6d695ff7d04cefd139590ab538d1be8f9a295eb9b0042406bdbfa60bb2b2545a428ec861e60f1cbf172050d47d0350bdb9 WHIRLPOOL 342d2ca503a6f6939ba10dde93937f1bb9b26459e4d5f98948996e59ee124a8a9d9fb0c9988dad8d0e242d3d5478ae3f5c62f975df43076a9f86f94ab8ef9348
+DIST inotify-tools-3.14.tar.gz 358772 SHA256 222bcca8893d7bf8a1ce207fb39ceead5233b5015623d099392e95197676c92f SHA512 6074d510e89bba5da0d7c4d86f2562c662868666ba0a7ea5d73e53c010a0050dd1fc01959b22cffdb9b8a35bd1b0b43c04d02d6f19927520f05889e8a9297dfb WHIRLPOOL fb22537b127ed8c03f4d0501d498c3731d7b85ce688ab8f281c7173d615c876d9ccd77b1d5a2a4effed642cfa30a99738b751608c9f279ce627ae951b41cada4
diff --git a/sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild b/sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild
new file mode 100644
index 000000000000..4e52d08f38ab
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/rvoicilas/inotify-tools/wiki"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ # timestamps are busted in tarball
+ find . -type f -exec touch -r configure {} +
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ econf \
+ --docdir=/usr/share/doc/${PF}/html \
+ $(use_enable doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README NEWS AUTHORS ChangeLog
+}
diff --git a/sys-fs/inotify-tools/inotify-tools-3.14.ebuild b/sys-fs/inotify-tools/inotify-tools-3.14.ebuild
new file mode 100644
index 000000000000..7dd8dc6af5d5
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/rvoicilas/inotify-tools/wiki"
+SRC_URI="http://github.com/downloads/rvoicilas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ~mips ~sparc x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ # timestamps are busted in tarball
+ find . -type f -exec touch -r configure {} +
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ econf \
+ --docdir=/usr/share/doc/${PF}/html \
+ $(use_enable doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README NEWS AUTHORS ChangeLog
+}
diff --git a/sys-fs/inotify-tools/metadata.xml b/sys-fs/inotify-tools/metadata.xml
new file mode 100644
index 000000000000..e91887d4fe6b
--- /dev/null
+++ b/sys-fs/inotify-tools/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription>
+inotify-tools is a set of command-line programs for Linux providing a simple
+interface to inotify. These programs can be used to monitor and act upon
+filesystem events. Requires a Linux kernel supporting inotify.
+</longdescription>
+ <upstream>
+ <remote-id type="github">downloads/rvoicilas</remote-id>
+ </upstream>
+</pkgmetadata>