summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/lde
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/lde')
-rw-r--r--sys-fs/lde/Manifest1
-rw-r--r--sys-fs/lde/files/lde-2.6.1-no-shadowing.patch39
-rw-r--r--sys-fs/lde/lde-2.6.1.ebuild33
-rw-r--r--sys-fs/lde/metadata.xml8
4 files changed, 81 insertions, 0 deletions
diff --git a/sys-fs/lde/Manifest b/sys-fs/lde/Manifest
new file mode 100644
index 000000000000..6097e8f9e6aa
--- /dev/null
+++ b/sys-fs/lde/Manifest
@@ -0,0 +1 @@
+DIST lde-2.6.1.tar.gz 598050 SHA256 d987555145a05d7b8c9f65e3f0f9754da1c29cc9933597d1765117b7ef3b0694
diff --git a/sys-fs/lde/files/lde-2.6.1-no-shadowing.patch b/sys-fs/lde/files/lde-2.6.1-no-shadowing.patch
new file mode 100644
index 000000000000..586bbf3e8768
--- /dev/null
+++ b/sys-fs/lde/files/lde-2.6.1-no-shadowing.patch
@@ -0,0 +1,39 @@
+rename daylight to avoid shadowing the daylight function and pissing off gcc
+
+http://bugs.gentoo.org/141881
+
+--- lde/src/swiped/cnews/getdate.y
++++ lde/src/swiped/cnews/getdate.y
+@@ -24,7 +24,7 @@
+
+ static int timeflag, dateflag, dayflag, relflag;
+ static time_t relsec, relmonth;
+- static int hh, mm, ss, merid, daylight;
++ static int hh, mm, ss, merid, foo_daylight;
+ static int dayord, dayreq;
+ static int month, day, year;
+ static int ourzone;
+@@ -68,19 +68,19 @@
+ {hh = $1; mm = $3; merid = $4;}
+ | NUMBER ':' NUMBER NUMBER
+ {hh = $1; mm = $3; merid = 24;
+- daylight = STANDARD; ourzone = $4%100 + 60*$4/100;}
++ foo_daylight = STANDARD; ourzone = $4%100 + 60*$4/100;}
+ | NUMBER ':' NUMBER ':' NUMBER
+ {hh = $1; mm = $3; ss = $5; merid = 24;}
+ | NUMBER ':' NUMBER ':' NUMBER MERIDIAN
+ {hh = $1; mm = $3; ss = $5; merid = $6;}
+ | NUMBER ':' NUMBER ':' NUMBER NUMBER
+ {hh = $1; mm = $3; ss = $5; merid = 24;
+- daylight = STANDARD; ourzone = $6%100 + 60*$6/100;};
++ foo_daylight = STANDARD; ourzone = $6%100 + 60*$6/100;};
+
+ zone: ZONE
+- {ourzone = $1; daylight = STANDARD;}
++ {ourzone = $1; foo_daylight = STANDARD;}
+ | DAYZONE
+- {ourzone = $1; daylight = DAYLIGHT;};
++ {ourzone = $1; foo_daylight = DAYLIGHT;};
+
+ dyspec: DAY
+ {dayord = 1; dayreq = $1;}
diff --git a/sys-fs/lde/lde-2.6.1.ebuild b/sys-fs/lde/lde-2.6.1.ebuild
new file mode 100644
index 000000000000..c80084b73f4f
--- /dev/null
+++ b/sys-fs/lde/lde-2.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="ext2fs and minix disk editor for linux"
+HOMEPAGE="http://lde.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ dev-util/yacc"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-shadowing.patch #141881
+}
+
+src_install() {
+ into /
+ dosbin lde || die
+ newman doc/lde.man lde.8
+ dodoc WARNING README TODO
+}
diff --git a/sys-fs/lde/metadata.xml b/sys-fs/lde/metadata.xml
new file mode 100644
index 000000000000..3a3de5497390
--- /dev/null
+++ b/sys-fs/lde/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <upstream>
+ <remote-id type="sourceforge">lde</remote-id>
+ </upstream>
+</pkgmetadata>