summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2017-06-11 23:41:11 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2017-06-11 23:41:11 -0400
commit463d97a5290f16675abd5af8735aa4e2f1637a4c (patch)
tree211f23488ac4e29bf4b5e14a032b0980d2749bca /sys-fs/vhba
parentsys-fs/vhba: fix build with kernel 4.11 and add epatch_user (diff)
downloadgentoo-463d97a5290f16675abd5af8735aa4e2f1637a4c.tar.gz
gentoo-463d97a5290f16675abd5af8735aa4e2f1637a4c.tar.bz2
gentoo-463d97a5290f16675abd5af8735aa4e2f1637a4c.zip
sys-fs/vhba: bump to 20170610, bug #618286
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-fs/vhba')
-rw-r--r--sys-fs/vhba/Manifest1
-rw-r--r--sys-fs/vhba/vhba-20170610.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-fs/vhba/Manifest b/sys-fs/vhba/Manifest
index b69d202047bf..2d180b185a9d 100644
--- a/sys-fs/vhba/Manifest
+++ b/sys-fs/vhba/Manifest
@@ -1,2 +1,3 @@
DIST vhba-module-20130607.tar.bz2 15528 SHA256 d2c4919d2904a8f880e2730250f7ed6e3143575d5c4de6b88a97c2228aa2a185 SHA512 7ac359a3a20920a3baac81d1dd941f4ea04d77cffaf4bc63dc2d9b9d0f80883be82c00a911ab17b9b0da3719bd10f6bc392edd00f9342a332da5c5f036dfc4d7 WHIRLPOOL 85623ce6ae303ebf55512410f10c9f0b524f298104bf9305ce403516c8c12897eb253ab8163da6137c16e719d1abee4206b1864b8a73e9fd58bc95a6621d211e
DIST vhba-module-20140928.tar.bz2 15571 SHA256 45f56e4972b5aa7175903307901ca42d29da6fc8f92ab4c47007f53bc5bb55a2 SHA512 efa61b2ac44a015582f99affa4c26e4b6ccdd1506a7f14626c08833c4ffff300d128dd4e9040d83d5a51064b0bc9f95397c3cdfec7197c53c3d6f1a97953f779 WHIRLPOOL 4b96bb5010b8ab892db09f7e8f36fc67107533dd4d6beea6d5b89e6076c44ee969bee5d3b646b4ca5b1f0f6af446096fd892ab0970b8d6893fe4730f3eb18c07
+DIST vhba-module-20170610.tar.bz2 15622 SHA256 7970c93f989d9c4f2629371bf5ee7a76f95e4c12342c3320ddc528d0df02d9ec SHA512 bf27a6a7a6aabf6c1a4c1f16b1a08dce460ee675ea53b141c6db8edf0637dffa900e03b9141f9f1a672fcd8f84e6f2be86a07e1f78bc5667a7a7669d45f1f687 WHIRLPOOL b5e9c8ae140e7267d11c3bab71879f49c3be464504193e06c8a77d291f22c41d9c017a8dc06477566b89b89430305aee71c2542a2d3ce04783f7f08e7122e730
diff --git a/sys-fs/vhba/vhba-20170610.ebuild b/sys-fs/vhba/vhba-20170610.ebuild
new file mode 100644
index 000000000000..0284af31548a
--- /dev/null
+++ b/sys-fs/vhba/vhba-20170610.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils linux-mod udev
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS=modules
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ # Avoid "make jobserver unavailable" warning and -Werror problems
+ sed -e '/ccflags/s/-Werror$/-Wall/' \
+ -i Makefile || die "sed failed"
+
+ eapply_user
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README
+ linux-mod_src_install
+
+ einfo "Generating udev rules ..."
+ dodir "$(get_udevdir)"/rules.d
+ cat > "${D}/$(get_udevdir)"/rules.d/69-vhba.rules <<-EOF || die
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
+ EOF
+}
+
+pkg_postinst() {
+ # Older versions of vhba installed their rule file in /etc/udev/rules.d,
+ # which overrides rules in /lib/udev/rules.d. We remove the old file
+ # automatically if it is identical to the default one installed by
+ # vhba-1.2.1 or 20101015-r1. Note that the comment at the top of the rules
+ # file states that it can be automatically overwritten by the system.
+ old_rules="${ROOT}etc/udev/rules.d/70-vhba.rules"
+ if [[ -f "${old_rules}" ]]; then
+ case "$(md5sum ${old_rules})" in
+ 2959b3cf61cfe6e466cc3516a7bc19de* | 1e7a7e5d6d28c811eeec98ec26ed5d28* )
+ elog
+ elog "Removing old ${old_rules} ..."
+ rm -f "${old_rules}" ||
+ eerror "Failed, please remove ${old_rules} manually."
+ ;;
+ * )
+ ewarn
+ ewarn "The ${old_rules} file from a previous"
+ ewarn "installation of ${PN} is overriding ${P}'s"
+ ewarn "udev rules. Unless you had deliberately customized it,"
+ ewarn "you should remove it."
+ ewarn
+ ;;
+ esac
+ fi
+
+ linux-mod_pkg_postinst
+}