summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-16 11:08:15 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-16 12:12:45 +0100
commit0a2fcf1b940a4a98cfc8657d23e50577dc2777b6 (patch)
tree44d7216f377bce97f72529369c9750c7bc65ec60 /sys-fs
parentnet-libs/gsoap: Removed old. (diff)
downloadgentoo-0a2fcf1b940a4a98cfc8657d23e50577dc2777b6.tar.gz
gentoo-0a2fcf1b940a4a98cfc8657d23e50577dc2777b6.tar.bz2
gentoo-0a2fcf1b940a4a98cfc8657d23e50577dc2777b6.zip
sys-fs/aufs4: Bump to latest aufs release
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs4/Manifest1
-rw-r--r--sys-fs/aufs4/aufs4-0_pre20151116.ebuild164
2 files changed, 165 insertions, 0 deletions
diff --git a/sys-fs/aufs4/Manifest b/sys-fs/aufs4/Manifest
index 23bdbff74eb8..91d51647c211 100644
--- a/sys-fs/aufs4/Manifest
+++ b/sys-fs/aufs4/Manifest
@@ -10,3 +10,4 @@ DIST aufs4-standalone-0_pre20150928.tar.xz 649700 SHA256 614a7d36577d9c432deba64
DIST aufs4-standalone-0_pre20151012.tar.xz 651492 SHA256 3cb564a71a4d4fe4f16c9412b5c714645739beea9471db421d76f1af2af86d83 SHA512 abf1833a4902dc95cce203607cd715b6794b13e064c073139bc06facfd86ceb817d00d7bed0f5420d8f8f7c9205524a8ffc9431dc1c0d2da1e73393b7d89d33d WHIRLPOOL a8cb9e8fc4449dbc54e1bfab1c9acb61e7dc31c33c62d8a2e2feb407bc6d4a2ceb502fd85ac7519af1e9b028603525ee26763438e04736fee138420796c13e90
DIST aufs4-standalone-0_pre20151102.tar.xz 677588 SHA256 5e0aa085e42dacc45991e49e485bf4f20cb911c71c8d5363ef2986733cb3d9ef SHA512 b4973078f31c50bb58afeb4fc5216a34d31b1dd4de60a5dd172962935becad60820146e22e39e88fc16a4c7a74e21923f02a77d6b0d8cd8aeef946806ed97932 WHIRLPOOL e04651079f1f04a74c330786ff3bbe72c367657ad8d0351ce251a4287ddee65231df410436f86474e6418b3e848eaa370f930376a2a1ad9fe57280b4d75be4cb
DIST aufs4-standalone-0_pre20151109.tar.xz 697760 SHA256 6dc6341cf729106d0f53b36f100c8d561992985f8dd8000a0956d716b10321a9 SHA512 dcacf98040bd51ad974582e1129b1993d8945b19449dd1e9ce855a5eb1502b05ab67196fa0f61e10eb45a3496d9866c0137122486ef9021704a59a41a7ffa944 WHIRLPOOL 2fd61080044b11f05514d55c9edabb345109cd217a7fcafdae3cc9c2cf8322a998da0f6416e20782ae9dfebd9483d7d87c3280bdf86d718bc2df993e11f2925a
+DIST aufs4-standalone-0_pre20151116.tar.xz 741280 SHA256 362d56dac519b35e73cb93b0ed61442e9cfd01da463ab92579f7e231543dec66 SHA512 425adac57115b61af0d0db713cf60dfbd2820464b4e9beae84ae14bb2e37d99b4e940a67c82aae1fb7b1693a4c812e606239e7f7b254d62105da14973200b40e WHIRLPOOL 5d336ba26ffc4a9daa2675f28d88b53a306224bc42b2751f3cbe7d1fa2c34d93fb0babec82ff6aa844de56cfc5ddda17fc9deb5f1e6d43efc4b3a19389096be0
diff --git a/sys-fs/aufs4/aufs4-0_pre20151116.ebuild b/sys-fs/aufs4/aufs4-0_pre20151116.ebuild
new file mode 100644
index 000000000000..e30e5f26aa7a
--- /dev/null
+++ b/sys-fs/aufs4/aufs4-0_pre20151116.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo toolchain-funcs
+
+AUFS_VERSION="${PV%%_p*}"
+# highest branch version
+PATCH_MAX_VER=3
+# highest supported version
+KERN_MAX_VER=4
+# lowest supported version
+KERN_MIN_VER=0
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs4-standalone-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"
+
+DEPEND="
+ dev-util/patchutils
+ dev-vcs/git"
+RDEPEND="
+ sys-fs/aufs-util
+ !sys-fs/aufs
+ !sys-fs/aufs2
+ !sys-fs/aufs3"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK+=" !AUFS_FS"
+ use inotify && CONFIG_CHECK+=" ~FSNOTIFY"
+ use nfs && CONFIG_CHECK+=" EXPORTFS"
+ use fuse && CONFIG_CHECK+=" ~FUSE_FS"
+ use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
+ use pax_kernel && CONFIG_CHECK+=" PAX" && ERROR_PAX="Please use hardened sources"
+
+ # this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
+ [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+
+ get_version
+ kernel_is lt 4 ${KERN_MIN_VER} 0 && die "the kernel version isn't supported by upstream anymore. Please upgrade."
+ kernel_is gt 4 ${KERN_MAX_VER} 99 && die "kernel too new"
+
+ linux-mod_pkg_setup
+
+ if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
+ PATCH_BRANCH="x-rcN"
+ else
+ PATCH_BRANCH="${KV_MINOR}"
+ fi
+
+ case ${KV_EXTRA} in
+ "")
+ elog "It seems you are using vanilla-sources with aufs4"
+ elog "Please use sys-kernel/aufs-sources with USE=vanilla"
+ elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
+ ;;
+ "-gentoo")
+ elog "It seems you are using gentoo-sources with aufs4"
+ elog "Please use sys-kernel/aufs-sources"
+ elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
+ ;;
+ esac
+
+ pushd "${T}" &> /dev/null
+ unpack ${A}
+ cd ${PN}-standalone || die
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+ einfo "Using ${module_branch} as patch source"
+ git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
+ combinediff ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
+ combinediff "${T}"/combined-1.patch ${PN}-mmap.patch > ${PN}-standalone-base-mmap-combined.patch
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch >/dev/null
+ epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ popd &> /dev/null
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+
+ einfo "Using for module creation branch ${module_branch}"
+ git checkout -q -b local-gentoo ${module_branch} || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ if use pax_kernel; then
+ epatch "${FILESDIR}"/pax-4.patch
+ fi
+
+ sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake \
+ CC=$(tc-getCC) \
+ LD=$(tc-getLD) \
+ LDFLAGS="$(raw-ldflags)" \
+ ARCH=$(tc-arch-kernel) \
+ CONFIG_AUFS_FS=m \
+ KDIR="${KV_OUT_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /usr/share/doc/${PF}
+
+ use doc && doins -r Documentation
+
+ use kernel-patch || doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+
+ dodoc Documentation/filesystems/aufs/README "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+ linux-mod_pkg_postinst
+}