summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-23 10:09:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-23 10:10:01 +0200
commitf25b8d6968d3235a831aadb2ab4cc47209a0442d (patch)
tree29d8ced5d2e52c3fef0e6e0acc106039fddd9c41 /sys-fs
parentdev-libs/userspace-rcu: Removed old. (diff)
downloadgentoo-f25b8d6968d3235a831aadb2ab4cc47209a0442d.tar.gz
gentoo-f25b8d6968d3235a831aadb2ab4cc47209a0442d.tar.bz2
gentoo-f25b8d6968d3235a831aadb2ab4cc47209a0442d.zip
sys-fs/multipath-tools: Bump to version 0.8.1
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/multipath-tools/Manifest1
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.8.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/Manifest b/sys-fs/multipath-tools/Manifest
index 89382fcf9fd1..4e8a400621de 100644
--- a/sys-fs/multipath-tools/Manifest
+++ b/sys-fs/multipath-tools/Manifest
@@ -1,3 +1,4 @@
DIST multipath-tools-0.6.4.tar.gz 285448 BLAKE2B 1b63c4e712e682965c595ed988a6590e181abd4d37779b72b52f4e415d4caba33df518a1ea1e3b460d15b5a78f4db5a75c1066439eb40c503023007c1f70752a SHA512 ec35c6c26c3b233ebece7136ea99dd4c0dff2927e7b543e7091219dc7065fe87e609a1eda9ab6d08399d44fe882d70c8dbe6be9ab175d154c5dd2d12ee1d86ea
DIST multipath-tools-0.7.9.tar.gz 419377 BLAKE2B 29003b7ce2d673eb59d869e2165028654361ca31f49b8e810d90611db249a5183492959d3aef778b870df7c1d283004bda88f3cc6f760569247f1ccc61617379 SHA512 6b237f148c239938b9f46a1a8118fc070372d5f2cfe2021c26ad9ca15d37e8866390168b6a4f13adcc5538001354247e072559a0add33ce1fe8245ae64ed0a3c
DIST multipath-tools-0.8.0.tar.gz 447076 BLAKE2B 10a93a2654decd2377414188013d2141e34288fe119fa7c54047d95b825ef9ae64b20de1067d3f37a904b58be587997842f7a62088701fe1c1e6a078283b56e4 SHA512 8b6081109e535d0e392233bcedda930bc6d4b529ebe23bc45b276026311bc997e3cf8b39c1a86e4962c464faa69512202c0f6fb3d1f06c6445f8141853ad1bc4
+DIST multipath-tools-0.8.1.tar.gz 447883 BLAKE2B c840ede03fd15763cd947a71596bf3a2e5935433d956208225f4fd6ed55074e2d9709f8b0e6c059a58d44b6649f52b3564d6651ea1af6186138357ba37f86b14 SHA512 1f87f974aace746ecac8af6ae330de16affe49cc89a5660b28be3b1c4a69f822da01042432176e64b5de6ad3a6568044954fdce8e3aa31e85611a595a4939947
diff --git a/sys-fs/multipath-tools/multipath-tools-0.8.1.ebuild b/sys-fs/multipath-tools/multipath-tools-0.8.1.ebuild
new file mode 100644
index 000000000000..956caa89e080
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.8.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit linux-info systemd toolchain-funcs udev vcs-snapshot toolchain-funcs
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="https://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=${PV};sf=tgz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="systemd rbd"
+
+RDEPEND="
+ dev-libs/json-c:=
+ dev-libs/libaio
+ dev-libs/userspace-rcu:=
+ >=sys-fs/lvm2-2.02.45
+ >=virtual/udev-171
+ sys-libs/readline:0=
+ rbd? ( sys-cluster/ceph )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+CONFIG_CHECK="~DM_MULTIPATH"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.7.5-respect-flags.patch )
+
+get_systemd_pv() {
+ use systemd && \
+ $(tc-getPKG_CONFIG) --modversion systemd
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # The upstream lacks any way to configure the build at present
+ # and ceph is a huge dependency, so we're using sed to make it
+ # optional until the upstream has a proper configure system
+ if ! use rbd ; then
+ sed \
+ -e "s/libcheckrbd.so/# libcheckrbd.so/" \
+ -e "s/-lrados//" \
+ -i libmultipath/checkers/Makefile \
+ || die
+ fi
+}
+
+src_compile() {
+ # LIBDM_API_FLUSH involves grepping files in /usr/include,
+ # so force the test to go the way we want #411337.
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDM_API_FLUSH=1 SYSTEMD="$(get_systemd_pv)"
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man{5,8}
+ emake \
+ DESTDIR="${D}" \
+ SYSTEMD=$(get_systemd_pv) \
+ unitdir="$(systemd_get_systemunitdir)" \
+ libudevdir='${prefix}'/"$(get_udevdir)" \
+ install
+
+ newinitd "${FILESDIR}"/rc-multipathd multipathd
+ newinitd "${FILESDIR}"/multipath.rc multipath
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+ fi
+}