summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-infiniband/libnes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-infiniband/libnes')
-rw-r--r--sys-infiniband/libnes/Manifest2
-rw-r--r--sys-infiniband/libnes/libnes-1.1.3-r1.ebuild30
-rw-r--r--sys-infiniband/libnes/libnes-1.1.4.ebuild30
-rw-r--r--sys-infiniband/libnes/metadata.xml11
4 files changed, 73 insertions, 0 deletions
diff --git a/sys-infiniband/libnes/Manifest b/sys-infiniband/libnes/Manifest
new file mode 100644
index 000000000000..ca457c585395
--- /dev/null
+++ b/sys-infiniband/libnes/Manifest
@@ -0,0 +1,2 @@
+DIST OFED-3.12-rc1.tgz 22055476 SHA256 14ca8a2b0d68e3ee9a37f475fa9eecd9a5ffd6055135f9d4d9db8319843a94dc SHA512 9f834d6982ab7e8ab47a8b5c958ab2e4c238ef983e47798e7f06655f69672ea1e996297939b381f26ed8c39552f6e62156173d5ddd2f0a7b6cad6aecdd973944 WHIRLPOOL 5a64b1d952890ea0e72e0ca93654a0fabc8f871475b05fcbe3b214ddfe4836f6b92d4fbc9e0f0d79acfe69d8c8d219b2c467c23654021e23eaf85ae6825ea4a9
+DIST OFED-3.5-rc2.tgz 18600237 SHA256 b267cea49bf72790843e6b08e26c10a6954d7736a8b93deed1e632772f4f5fff SHA512 deb83c3417ac60bd5d4c6ac1cadf93d6a34a55ca58365b54bb0c3a8230ba6a7f13e0257515dac0170cc4ab46b558519c86e6c01f7fa49550162feed0b0ea2e89 WHIRLPOOL e6843593fbe4937ffcf600be9cb3dee78e14cbeb4c411a4b64076b1194653cbcb9d4bc6cbd52ad77ac9c6b14d4dd2cdafa4364bfe6924b55896844042aa4d9cd
diff --git a/sys-infiniband/libnes/libnes-1.1.3-r1.ebuild b/sys-infiniband/libnes/libnes-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..0588d92d2a2d
--- /dev/null
+++ b/sys-infiniband/libnes/libnes-1.1.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+OFED_VER="3.5"
+OFED_RC="1"
+OFED_RC_VER="2"
+OFED_SUFFIX="1"
+
+inherit openib
+
+DESCRIPTION="NetEffect RNIC Userspace Library"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+DEPEND="sys-infiniband/libibverbs:${SLOT}"
+RDEPEND="${DEPEND}
+ !sys-infiniband/openib-userspace"
+block_other_ofed_versions
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"usr/$(get_libdir)/${PN}.la
+}
diff --git a/sys-infiniband/libnes/libnes-1.1.4.ebuild b/sys-infiniband/libnes/libnes-1.1.4.ebuild
new file mode 100644
index 000000000000..578e9ad53af6
--- /dev/null
+++ b/sys-infiniband/libnes/libnes-1.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OFED_VER="3.12"
+OFED_RC="1"
+OFED_RC_VER="1"
+OFED_SUFFIX="0"
+
+inherit openib
+
+DESCRIPTION="NetEffect RNIC Userspace Library"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+DEPEND="sys-infiniband/libibverbs:${SLOT}"
+RDEPEND="${DEPEND}
+ !sys-infiniband/openib-userspace"
+block_other_ofed_versions
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"usr/$(get_libdir)/${PN}.la
+}
diff --git a/sys-infiniband/libnes/metadata.xml b/sys-infiniband/libnes/metadata.xml
new file mode 100644
index 000000000000..f32cc6d6c3ca
--- /dev/null
+++ b/sys-infiniband/libnes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+<longdescription>
+libibverbs is a library that allows programs to use InfiniBand "verbs"
+for direct access to IB hardware from userspace. For more information
+on verbs, see the InfiniBand Architecture Specification vol. 1,
+especially chapter 11.
+</longdescription>
+</pkgmetadata>