summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2015-08-24 06:02:20 -0400
committerMike Pagano <mpagano@gentoo.org>2015-08-24 06:02:20 -0400
commit2e6507be18b3161abbe26dc372e73611d5b0999a (patch)
tree7647acaf5ba86dae6f0c9e943e077355c04cfc78 /sys-kernel/git-sources/git-sources-4.2_rc8.ebuild
parentmedia-sound/apulse: Revbump to 0.1.6-r1 (diff)
downloadgentoo-2e6507be18b3161abbe26dc372e73611d5b0999a.tar.gz
gentoo-2e6507be18b3161abbe26dc372e73611d5b0999a.tar.bz2
gentoo-2e6507be18b3161abbe26dc372e73611d5b0999a.zip
Linux patch 4.2_rc8
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-kernel/git-sources/git-sources-4.2_rc8.ebuild')
-rw-r--r--sys-kernel/git-sources/git-sources-4.2_rc8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/git-sources-4.2_rc8.ebuild b/sys-kernel/git-sources/git-sources-4.2_rc8.ebuild
new file mode 100644
index 000000000000..5355a7bc37e1
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.2_rc8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_BASE_VER="4.1"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}