summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-12-29 19:44:02 -0500
committerMike Pagano <mpagano@gentoo.org>2019-12-29 19:44:02 -0500
commit2ac9af45a2d1647df08c37f9eab1ec2d88730e4a (patch)
treed57f9dc7f4f36dd54c1a9708d8b12f9a93bdf390 /sys-kernel/git-sources
parentsys-kernel/ck-sources: Linux patch 5.4.6 (diff)
downloadgentoo-2ac9af45a2d1647df08c37f9eab1ec2d88730e4a.tar.gz
gentoo-2ac9af45a2d1647df08c37f9eab1ec2d88730e4a.tar.bz2
gentoo-2ac9af45a2d1647df08c37f9eab1ec2d88730e4a.zip
sys-kernel/git-sources: Linux patch 5.5-rc4
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.5_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index c24ad49c380e..ed7b788837ab 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.4.tar.xz 109441440 BLAKE2B 193bc4a3147e147d5529956164ec4912fad5d5c6
DIST patch-5.5-rc1.patch 42346664 BLAKE2B 5dd2f44ef640b718f27201225eddc9c8b85739c9e9bd0902dacbc8c88ee967c38209dff28a77ed9f392842d24937c264a25155b2cb584b853375a0ab17427257 SHA512 a4f2b07002e69768e86f77c3f795fc752567fef0ba1f9370c773b5170df5f3ff467167308c262fce4da820f8f2f4a6683fc64b3fa68aa78ac39954e59a1df500
DIST patch-5.5-rc2.patch 42752329 BLAKE2B 1365e47a57cb9938f72f7141fe2a0308bc0ca308f778465a9d9a65b7b6ce142f3a9fdf82472e7904f982d854a6e5c36b271c71b236eccfadf79ac1c1de28b80a SHA512 a451a75db4bc6c031fa70e97e70c31d71c2fbdd836d6c82cc5883ef1fa1767bdb902751c6ec71ac7f7182b20baba01599815ba72cd621b960a3a47b583281666
DIST patch-5.5-rc3.patch 43336020 BLAKE2B 3bc5729452ab2a07c1a01808f545a80cd69e8eeb317199052ca8678625bfe594a59b2b8aac4e2ace01b0b43394c0014245b0303e2b2b4aa9a055b13d9edeb4ac SHA512 119e1ca3739712a9da5f9c6a019f9ed3536cb1f2e03422093fae042414c2f47b9dff0b02438987af5fdffdba664d7ccb82203d14ee41c6a9a2a07b96877d4ea5
+DIST patch-5.5-rc4.patch 43379977 BLAKE2B a38ca7abade329ae966bfafe9f5c616c49d6a2afe2323a2835b4bb37c65d943d7b4b0224355d228a83c7a939aa3daa41b4d496ea2b808456bce2269dc6335bf3 SHA512 7a36ac95a934cfdad4fb1e082157c0e0a63d9658916f0889d4ef38b11c5b7d9ba2e57ec16897cb8987a134c2338ddc757e1f698661c6392cf7890571f6c08a8d
diff --git a/sys-kernel/git-sources/git-sources-5.5_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.5_rc4.ebuild
new file mode 100644
index 000000000000..84c23682a58e
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.5_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.4"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}