summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2016-09-05 19:28:54 -0400
committerMike Pagano <mpagano@gentoo.org>2016-09-05 19:28:54 -0400
commit3e909567477932028cb0d40e8d2aaf12a28d8568 (patch)
tree61c5bd8bb95fdbb9442d362c2ac59545d373cb69 /sys-kernel
parentsys-apps/systemd: adjust SECCOMP kernel checks (diff)
downloadgentoo-3e909567477932028cb0d40e8d2aaf12a28d8568.tar.gz
gentoo-3e909567477932028cb0d40e8d2aaf12a28d8568.tar.bz2
gentoo-3e909567477932028cb0d40e8d2aaf12a28d8568.zip
sys-kernel/git-sources: Linux patch 4.8-rc5
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.8_rc5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index bed2e711d0fe..a0912435af59 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-4.8-rc1.xz 6519232 SHA256 e7f3214d3718a6f92de61e3849d358e17f526ae4c82
DIST patch-4.8-rc2.xz 6562096 SHA256 148b8c5879315d80f32ffe2aebcfeb0fb91545e2e194362b37bef50a696d195d SHA512 8fac25899d2d5987ccbb1495ed6dbdd0c0a670c7c7dc937ed74376ba678bf95d1966d52d497bb319e14b619eb8ad2ccb2654adac9fb59eb0e9ad4a9936d00f80 WHIRLPOOL d1edbd67d7f3e5673e0ee7d22011da851fbbd13c765e07c7deb32c08c6955810c424c169459a756933d429bb21c81d6d2803d97835fcd8ce797b6d44234b50a7
DIST patch-4.8-rc3.xz 6623408 SHA256 f0aa7b462f13494a39d3c54dc73811c6381ec9f40b58ae956092df0411d576db SHA512 3858fabadba3a1771989a128e79e4930f4d98a52c05a3149bbfb9c09bae0895c5f6c52b8066b4df5d96ecc477f142d99c291e002ce8e27baa464889eec65d510 WHIRLPOOL fe02d94f19123932c5fc79a48d75582c4a49f428a8fbffba2742723c354c0b9b502b60f07bf12114846d83b21fcaf9ed4c3c7dd742793d718bbd1bfc0e93bb00
DIST patch-4.8-rc4.xz 6655212 SHA256 56832aae956174d01cf5381947fbb6a0339902285aab2d3ffc804028a4fc5d4a SHA512 fc4c6e3860cdc71020caa07d84b6b3bc95242e41fea81c8b3273453ea118df779ed835eae3f09f437aa0260cea332cbed7f2c3908b822b4d620859a960e77f6f WHIRLPOOL 0bf776053567925b7460c5b17baf841d44296d4f9910139dad425f439e541b35f74302fd13cfa1d8baceaeb415f101b99de89a698bb0e543d5be62fee2de6b34
+DIST patch-4.8-rc5.xz 6708372 SHA256 5d3bb6f9c07fefc102669e905765b7d2ec4be746594ace5510b7f355f1b1f0f0 SHA512 09e18d12e292022879983f3f2e096920c3e9e3158adecce06130ba3a2c43a753c6df732eb830e3a61313852b6ef122f7edf110ed3b172e678dc96edddcace17e WHIRLPOOL 75fb5293936d185f62a3bd55309bd1a86ea4204cb8b67c2bf15434d69ef078284382631e851ef2914998db265cebd27d6838e8a7538727cbef1063a77a82cdb8
diff --git a/sys-kernel/git-sources/git-sources-4.8_rc5.ebuild b/sys-kernel/git-sources/git-sources-4.8_rc5.ebuild
new file mode 100644
index 000000000000..1cef6aa3d6af
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.8_rc5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.7"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}