summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-01-20 08:38:28 +0100
committerAgostino Sarubbo <ago@gentoo.org>2020-01-20 08:38:28 +0100
commitd89699688fad0e2fce8d23aa189e2428d105e4bd (patch)
tree600a97242a92a5aae1eb24240719b647d756a197 /sys-kernel
parentsys-kernel/vanilla-sources: Automated version bump to {4.14.166,4.19.97,5.4.1... (diff)
downloadgentoo-d89699688fad0e2fce8d23aa189e2428d105e4bd.tar.gz
gentoo-d89699688fad0e2fce8d23aa189e2428d105e4bd.tar.bz2
gentoo-d89699688fad0e2fce8d23aa189e2428d105e4bd.zip
sys-kernel/git-sources: Automated version bump to 5.5_rc7.
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.5_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 5677e93c50c8..765a82205588 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.5-rc3.patch 43336020 BLAKE2B 3bc5729452ab2a07c1a01808f545a80cd69e8e
DIST patch-5.5-rc4.patch 43379977 BLAKE2B a38ca7abade329ae966bfafe9f5c616c49d6a2afe2323a2835b4bb37c65d943d7b4b0224355d228a83c7a939aa3daa41b4d496ea2b808456bce2269dc6335bf3 SHA512 7a36ac95a934cfdad4fb1e082157c0e0a63d9658916f0889d4ef38b11c5b7d9ba2e57ec16897cb8987a134c2338ddc757e1f698661c6392cf7890571f6c08a8d
DIST patch-5.5-rc5.patch 43553852 BLAKE2B 06b996fded42eeabc082ede5867b62bfedd75b17fdb72bf34eeee12bb2cf391e7a6c98485fe1bfa2aa2c71a89bf9118ad18fb436d5228c1a81b6d3ceb1595bfd SHA512 ea1e206de9513bce3d6cd67b33f6b2311c141c11f1facdaffa0af09f8057f554a6f05ba682218a9f0f384995e773bbe08e3558263821b13f1c46df54db76bffe
DIST patch-5.5-rc6.patch 43727222 BLAKE2B e17d108d073441237114984b5615ba17cbd07b7a4521a1b87dd41bf9d4194ad340a9a62adab3ce866151112a55090c3958df5a3c1f3fc6e321c876d70cebf219 SHA512 7596cccb5ac54be9b70d24ff222e20fbbc2285f59bda4402e173b0e6c8dd0060f2544ed688edd5620bca00ffbf93f6262c33a332c64d331854a23ce16589e0c2
+DIST patch-5.5-rc7.patch 43993068 BLAKE2B eb6da463376791dc87d96675b7c7e962e7c89c9cbf9c8f7d3bfe995d702bfd6a7fb42801efca48404f100654dd618842c5f21350bf17b13f1b353b43830fc71d SHA512 02f7571e947cfa695b05eb65a36f42621bca993e0c9d32ea972334d358798fd66a8f2751a819c599f5d51f58d1264a6edf73a7cd2bb752329bc81ae300d3ded5
diff --git a/sys-kernel/git-sources/git-sources-5.5_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.5_rc7.ebuild
new file mode 100644
index 000000000000..db3e3f95cd35
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.5_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.4"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}