summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-25 08:33:26 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-25 08:33:26 +0100
commitec9a106deef4fc52c5f81a1ef52e18af323f2513 (patch)
treeb499961badddf7788a916dcefb9cc28872ab39fe /sys-libs/binutils-libs/binutils-libs-2.30-r4.ebuild
parentsys-devel/binutils-hppa64: release patchset 5 for 2.30 (diff)
downloadgentoo-ec9a106deef4fc52c5f81a1ef52e18af323f2513.tar.gz
gentoo-ec9a106deef4fc52c5f81a1ef52e18af323f2513.tar.bz2
gentoo-ec9a106deef4fc52c5f81a1ef52e18af323f2513.zip
sys-libs/binutils-libs: release patchset 5 for 2.30
One new main patch: + 0098-Gentoo-add-with-extra-soversion-suffix-option.patch And four backports: + 0094-Replace-CET-bit-with-IBT-and-SHSTK-bits.patch + 0095-Fix-parens-in-ld-bootstrap.exp.patch + 0096-x86-64-Clear-the-R_X86_64_converted_reloc_bit-bit.patch + 0097-Fix-unwind-offset-for-call_info-start_symbol.patch Changes SONAME from libopcodes-2.30.so to libopcodes-2.30.gentoo-sys-libs-binutils-libs-mt-def.so SONAME now encodes USE=multilib and package name. Bug: https://bugs.gentoo.org/663690 Bug: https://bugs.gentoo.org/666376 Bug: https://bugs.gentoo.org/666100 Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'sys-libs/binutils-libs/binutils-libs-2.30-r4.ebuild')
-rw-r--r--sys-libs/binutils-libs/binutils-libs-2.30-r4.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/sys-libs/binutils-libs/binutils-libs-2.30-r4.ebuild b/sys-libs/binutils-libs/binutils-libs-2.30-r4.ebuild
new file mode 100644
index 000000000000..5894685fb9bb
--- /dev/null
+++ b/sys-libs/binutils-libs/binutils-libs-2.30-r4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PATCH_VER=5
+
+inherit eutils toolchain-funcs multilib-minimal
+
+MY_PN="binutils"
+MY_P="${MY_PN}-${PV}"
+PATCH_BINUTILS_VER=${PATCH_BINUTILS_VER:-${PV}}
+PATCH_DEV=${PATCH_DEV:-slyfox}
+
+DESCRIPTION="Core binutils libraries (libbfd, libopcodes, libiberty) for external packages"
+HOMEPAGE="https://sourceware.org/binutils/"
+SRC_URI="mirror://gnu/binutils/${MY_P}.tar.xz
+ https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${MY_PN}-${PATCH_BINUTILS_VER}-patches-${PATCH_VER}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+# The shared lib SONAMEs use the ${PV} in them.
+# -r1 is a one-off subslot bump where SONAME changed for bug #666100
+SLOT="0/${PV}-r1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="64-bit-bfd multitarget nls static-libs"
+
+COMMON_DEPEND="sys-libs/zlib[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
+ >=sys-apps/texinfo-4.7
+ nls? ( sys-devel/gettext )"
+# Need a newer binutils-config that'll reset include/lib symlinks for us.
+RDEPEND="${COMMON_DEPEND}
+ >=sys-devel/binutils-config-5
+ nls? ( !<sys-devel/gdb-7.10-r1[nls] )"
+
+S="${WORKDIR}/${MY_P}"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/bfd.h
+)
+
+src_prepare() {
+ if [[ ! -z ${PATCH_VER} ]] ; then
+ einfo "Applying binutils-${PATCH_BINUTILS_VER} patchset ${PATCH_VER}"
+ eapply "${WORKDIR}/patch"/*.patch
+ fi
+ default
+}
+
+pkgversion() {
+ printf "Gentoo ${PVR}"
+ [[ -n ${PATCHVER} ]] && printf " p${PATCHVER}"
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-obsolete
+ --enable-shared
+ --enable-threads
+ # Newer versions (>=2.24) make this an explicit option. #497268
+ --enable-install-libiberty
+ --disable-werror
+ --with-bugurl="https://bugs.gentoo.org/"
+ --with-pkgversion="$(pkgversion)"
+ $(use_enable static-libs static)
+ # The binutils eclass enables this flag for all bi-arch builds,
+ # but other tools often don't care about that support. Put it
+ # beyond a flag if people really want it, but otherwise leave
+ # it disabled as it can slow things down on 32bit arches. #438522
+ $(use_enable 64-bit-bfd)
+ # This only disables building in the zlib subdir.
+ # For binutils itself, it'll use the system version. #591516
+ --without-zlib
+ --with-system-zlib
+ # We only care about the libs, so disable programs. #528088
+ --disable-{binutils,etc,ld,gas,gold,gprof}
+ # Disable modules that are in a combined binutils/gdb tree. #490566
+ --disable-{gdb,libdecnumber,readline,sim}
+ # Strip out broken static link flags.
+ # https://gcc.gnu.org/PR56750
+ --without-stage1-ldflags
+ # We pull in all USE-flags that change ABI in an incompatible
+ # way. #666100
+ # USE=multitarget change size of global arrays
+ # USE=64-bit-bfd changes data structures of exported API
+ --with-extra-soversion-suffix=gentoo-${CATEGORY}-${PN}-$(usex multitarget mt st)-$(usex 64-bit-bfd 64 def)
+ )
+
+ # mips can't do hash-style=gnu ...
+ if [[ $(tc-arch) != mips ]] ; then
+ myconf+=( --enable-default-hash-style=gnu )
+ fi
+
+ use multitarget && myconf+=( --enable-targets=all --enable-64-bit-bfd )
+
+ use nls \
+ && myconf+=( --without-included-gettext ) \
+ || myconf+=( --disable-nls )
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+ # Provide libiberty.h directly.
+ dosym libiberty/libiberty.h /usr/include/libiberty.h
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}