summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-16 15:11:43 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-16 15:16:23 +0100
commit3a9d5d6444a89b5da5889e12454ce98d94a79140 (patch)
tree9d347bf957efca22630aaaeaa94f8a9a17370ec6 /sys-libs/compiler-rt-sanitizers
parentsys-libs/compiler-rt: Prefer building using clang (diff)
downloadgentoo-3a9d5d6444a89b5da5889e12454ce98d94a79140.tar.gz
gentoo-3a9d5d6444a89b5da5889e12454ce98d94a79140.tar.bz2
gentoo-3a9d5d6444a89b5da5889e12454ce98d94a79140.zip
sys-libs/compiler-rt-sanitizers: Use strip-unsupported-flags
Use strip-unsupported-flags to strip flags not supported by clang instead of a hardcoded known-bad flag list.
Diffstat (limited to 'sys-libs/compiler-rt-sanitizers')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.0_rc2.ebuild4
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.0_rc2.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.0_rc2.ebuild
index 679d166d733f..2c004b0a3a2a 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.0_rc2.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.0_rc2.ebuild
@@ -74,7 +74,9 @@ src_configure() {
# same flags are passed for build & tests, so we need to strip
# them down to a subset supported by clang
- filter-flags -msahf -frecord-gcc-switches
+ CC=${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang \
+ CXX=${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang++ \
+ strip-unsupported-flags
fi
cmake-utils_src_configure
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
index 6e4198615177..4d66c86e90b6 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
@@ -80,7 +80,9 @@ src_configure() {
# same flags are passed for build & tests, so we need to strip
# them down to a subset supported by clang
- filter-flags -msahf -frecord-gcc-switches
+ CC=${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang \
+ CXX=${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang++ \
+ strip-unsupported-flags
fi
cmake-utils_src_configure