summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-03 21:08:43 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-03 21:39:17 +0200
commit4434763ebfbc98e64a348d1432c90d6c224ba3b3 (patch)
tree8c93f2d7a76d2cf02e6753b8661d214a8d13f914 /sys-libs/compiler-rt-sanitizers
parentsys-devel/clang-runtime: Add USE=crt for (non-GCC) crt*.o files (diff)
downloadgentoo-4434763ebfbc98e64a348d1432c90d6c224ba3b3.tar.gz
gentoo-4434763ebfbc98e64a348d1432c90d6c224ba3b3.tar.bz2
gentoo-4434763ebfbc98e64a348d1432c90d6c224ba3b3.zip
sys-libs/compiler-rt-sanitizers: Backport sandbox-2.13 use to 4/5
Update the 4.0.1 and 5.0.1 versions to rely on sandbox-2.13 unloading support instead of using unsandbox.
Diffstat (limited to 'sys-libs/compiler-rt-sanitizers')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.1.ebuild8
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-5.0.1.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.1.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.1.ebuild
index 2dc0d7cb40bd..78b0975433f4 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.1.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-4.0.1.ebuild
@@ -28,7 +28,7 @@ DEPEND="
>=sys-devel/llvm-4
clang? ( sys-devel/clang )
test? (
- app-portage/unsandbox
+ !<sys-apps/sandbox-2.13
$(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
sys-libs/compiler-rt:${SLOT} )
@@ -108,7 +108,7 @@ src_configure() {
if use test; then
mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLIT_COMMAND="${EPREFIX}/usr/bin/unsandbox;${EPREFIX}/usr/bin/lit"
+ -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
# they are created during src_test()
-DCOMPILER_RT_TEST_COMPILER="${BUILD_DIR}/lib/llvm/${CLANG_SLOT}/bin/clang"
@@ -149,6 +149,10 @@ src_configure() {
src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
+ # disable sandbox to have it stop clobbering LD_PRELOAD
+ local -x SANDBOX_ON=0
+ # wipe LD_PRELOAD to make ASAN happy
+ local -x LD_PRELOAD=
cmake-utils_src_make check-all
}
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-5.0.1.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-5.0.1.ebuild
index b09a0573d92a..ccfea7940925 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-5.0.1.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-5.0.1.ebuild
@@ -29,7 +29,7 @@ DEPEND="
>=sys-devel/llvm-4
clang? ( sys-devel/clang )
test? (
- app-portage/unsandbox
+ !<sys-apps/sandbox-2.13
$(python_gen_any_dep ">=dev-python/lit-5[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
sys-libs/compiler-rt:${SLOT} )
@@ -112,7 +112,7 @@ src_configure() {
if use test; then
mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLIT_COMMAND="${EPREFIX}/usr/bin/unsandbox;${EPREFIX}/usr/bin/lit"
+ -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
# they are created during src_test()
-DCOMPILER_RT_TEST_COMPILER="${BUILD_DIR}/lib/llvm/${CLANG_SLOT}/bin/clang"
@@ -160,6 +160,10 @@ src_configure() {
src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
+ # disable sandbox to have it stop clobbering LD_PRELOAD
+ local -x SANDBOX_ON=0
+ # wipe LD_PRELOAD to make ASAN happy
+ local -x LD_PRELOAD=
cmake-utils_src_make check-all
}