summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-10-13 13:18:18 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-10-13 14:17:44 +0200
commitdafbc798a1d73b3f625a9119334f16774db1c601 (patch)
tree9bf34f3fe27b5f9e87acf877bfaa4dbc4e52ebb2 /sys-libs/gdbm
parentmedia-sound/grip: stable 3.4.3 for ppc64, bug #626864 (diff)
downloadgentoo-dafbc798a1d73b3f625a9119334f16774db1c601.tar.gz
gentoo-dafbc798a1d73b3f625a9119334f16774db1c601.tar.bz2
gentoo-dafbc798a1d73b3f625a9119334f16774db1c601.zip
sys-libs/gdbm: Fix a typo in gdbm.h
Closes: https://bugs.gentoo.org/612530 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'sys-libs/gdbm')
-rw-r--r--sys-libs/gdbm/files/gdbm-1.13-fix-a-typo-in-gdbm.h.patch21
-rw-r--r--sys-libs/gdbm/gdbm-1.13-r1.ebuild70
2 files changed, 91 insertions, 0 deletions
diff --git a/sys-libs/gdbm/files/gdbm-1.13-fix-a-typo-in-gdbm.h.patch b/sys-libs/gdbm/files/gdbm-1.13-fix-a-typo-in-gdbm.h.patch
new file mode 100644
index 000000000000..f3b96e9be2c7
--- /dev/null
+++ b/sys-libs/gdbm/files/gdbm-1.13-fix-a-typo-in-gdbm.h.patch
@@ -0,0 +1,21 @@
+From 1e0b3f4556f88013a2268bb2ef0c8d4bfaa40f90 Mon Sep 17 00:00:00 2001
+From: Sergey Poznyakoff <gray@gnu.org.ua>
+Date: Fri, 14 Apr 2017 07:48:35 +0000
+Subject: Fix a typo
+
+---
+diff --git a/src/gdbm.h.in b/src/gdbm.h.in
+index e9b7b1b..de0d2b9 100644
+--- a/src/gdbm.h.in
++++ b/src/gdbm.h.in
+@@ -224,7 +224,7 @@ extern int gdbm_copy_meta (GDBM_FILE dst, GDBM_FILE src);
+ # define _GDBM_MAX_ERRNO GDBM_DIR_OVERFLOW
+
+ /* This one was never used and will be removed in the future */
+-# define GDBM_UNKNOWN_UPDATE GDBM_ERR_UNKNOWN_ERROR
++# define GDBM_UNKNOWN_UPDATE GDBM_UNKNOWN_ERROR
+
+ typedef int gdbm_error;
+ extern gdbm_error gdbm_errno;
+--
+cgit v0.9.0.3
diff --git a/sys-libs/gdbm/gdbm-1.13-r1.ebuild b/sys-libs/gdbm/gdbm-1.13-r1.ebuild
new file mode 100644
index 000000000000..022e74618c7a
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.13-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic multilib multilib-minimal
+
+EX_P="${PN}-1.8.3"
+DESCRIPTION="Standard GNU database libraries"
+HOMEPAGE="https://www.gnu.org/software/gdbm/"
+SRC_URI="mirror://gnu/gdbm/${P}.tar.gz
+ exporter? ( mirror://gnu/gdbm/${EX_P}.tar.gz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+berkdb exporter nls +readline static-libs"
+
+DEPEND="
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/gdbm-1.13-fix-a-typo-in-gdbm.h.patch
+)
+
+EX_S="${WORKDIR}/${EX_P}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # gdbm doesn't appear to use either of these libraries
+ export ac_cv_lib_dbm_main=no ac_cv_lib_ndbm_main=no
+
+ if multilib_is_native_abi && use exporter ; then
+ pushd "${EX_S}" >/dev/null
+ append-lfs-flags
+ econf --disable-shared
+ popd >/dev/null
+ fi
+
+ local myeconfargs=(
+ --includedir="${EPREFIX}"/usr/include/gdbm
+ --with-gdbm183-libdir="${EX_S}/.libs"
+ --with-gdbm183-includedir="${EX_S}"
+ $(use_enable berkdb libgdbm-compat)
+ $(multilib_native_use_enable exporter gdbm-export)
+ $(use_enable nls)
+ $(use_enable static-libs static)
+ $(use_with readline)
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ use exporter && emake -C "${EX_S}" libgdbm.la
+ emake
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+ mv "${ED%/}"/usr/include/gdbm/gdbm.h "${ED%/}"/usr/include/ || die
+}