summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-30 17:56:57 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-30 18:34:33 -0400
commit838c3028555eb9d8f12017dcf43f0c7b0c8af90f (patch)
tree00d3eda6d5617ef96ac1fac3c65fccf4a6824baf /sys-libs/gpm
parentwww-client/google-chrome-beta: automated update (diff)
downloadgentoo-838c3028555eb9d8f12017dcf43f0c7b0c8af90f.tar.gz
gentoo-838c3028555eb9d8f12017dcf43f0c7b0c8af90f.tar.bz2
gentoo-838c3028555eb9d8f12017dcf43f0c7b0c8af90f.zip
toolchain-funcs.eclass: gen_usr_ldscript: integrate multilib_is_native_abi support #479448
Many ebuilds have started checking multilib_is_native_abi to see if they should call gen_usr_ldscript. Since that logic always makes sense, add it directly to the gen_usr_ldscript function.
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/gpm-1.20.7-r2.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-libs/gpm/gpm-1.20.7-r2.ebuild b/sys-libs/gpm/gpm-1.20.7-r2.ebuild
index 8a191ddd479..ee9f5a7005e 100644
--- a/sys-libs/gpm/gpm-1.20.7-r2.ebuild
+++ b/sys-libs/gpm/gpm-1.20.7-r2.ebuild
@@ -62,7 +62,7 @@ multilib_src_install() {
install
dosym libgpm.so.1 /usr/$(get_libdir)/libgpm.so
- multilib_is_native_abi && gen_usr_ldscript -a gpm
+ gen_usr_ldscript -a gpm
}
multilib_src_install_all() {