summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sys-libs/libcxxrt
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/libcxxrt')
-rw-r--r--sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild1
-rw-r--r--sys-libs/libcxxrt/libcxxrt-9999.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild b/sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild
index bb89489c09da..5f6ec8f7caaa 100644
--- a/sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild
+++ b/sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild
@@ -26,6 +26,7 @@ else
KEYWORDS="amd64 arm arm64 x86"
fi
IUSE="+libunwind +static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="libunwind? ( || ( >=sys-libs/libunwind-1.0.1-r1[static-libs?,${MULTILIB_USEDEP}]
sys-libs/llvm-libunwind[static-libs?,${MULTILIB_USEDEP}] ) )"
diff --git a/sys-libs/libcxxrt/libcxxrt-9999.ebuild b/sys-libs/libcxxrt/libcxxrt-9999.ebuild
index 5374e99ec390..2fdf7d613327 100644
--- a/sys-libs/libcxxrt/libcxxrt-9999.ebuild
+++ b/sys-libs/libcxxrt/libcxxrt-9999.ebuild
@@ -26,6 +26,7 @@ else
KEYWORDS=""
fi
IUSE="+libunwind +static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="libunwind? ( || ( >=sys-libs/libunwind-1.0.1-r1[static-libs?,${MULTILIB_USEDEP}]
sys-libs/llvm-libunwind[static-libs?,${MULTILIB_USEDEP}] ) )"