summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas D <whissi@whissi.de>2015-12-14 14:10:38 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-14 14:22:04 -0500
commit2e5ed736019cf2fd7e9db25189d1ac6b070337c4 (patch)
tree3ac260088dd4b71b0cfead30d2ffb16f4c908085 /sys-libs/libhugetlbfs/libhugetlbfs-2.19-r1.ebuild
parentsys-libs/libhugetlbfs: do not gzip manpages (diff)
downloadgentoo-2e5ed736019cf2fd7e9db25189d1ac6b070337c4.tar.gz
gentoo-2e5ed736019cf2fd7e9db25189d1ac6b070337c4.tar.bz2
gentoo-2e5ed736019cf2fd7e9db25189d1ac6b070337c4.zip
sys-libs/libhugetlbfs: control python usage during testing
The test code uses python, and only supports py2, so make sure the ebuild expresses those requirements when the default is py3.
Diffstat (limited to 'sys-libs/libhugetlbfs/libhugetlbfs-2.19-r1.ebuild')
-rw-r--r--sys-libs/libhugetlbfs/libhugetlbfs-2.19-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-libs/libhugetlbfs/libhugetlbfs-2.19-r1.ebuild b/sys-libs/libhugetlbfs/libhugetlbfs-2.19-r1.ebuild
index 4cdb5d49f2d4..484785433f02 100644
--- a/sys-libs/libhugetlbfs/libhugetlbfs-2.19-r1.ebuild
+++ b/sys-libs/libhugetlbfs/libhugetlbfs-2.19-r1.ebuild
@@ -2,9 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI="5"
-inherit eutils multilib toolchain-funcs perl-functions
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib toolchain-funcs perl-functions python-any-r1
DESCRIPTION="easy hugepage access"
HOMEPAGE="https://github.com/libhugetlbfs/libhugetlbfs"
@@ -15,7 +17,9 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="static-libs"
+IUSE="static-libs test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
RDEPEND="dev-lang/perl:="
src_prepare() {